POJ3258——River Hopscotch(二分)

River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12251 Accepted: 5250

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, Lunits away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers:  LN, and  M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).


一条河里有n个石头,从一边到岸的另一边,你可以移去m个石头,使得最近的两个石头之间的距离最大。

最大化最小值,标准二分法

具体在判断一个距离是否可行的时候。选择使用两个标志,一个指向当前没有被移去的石头,一个指向下一个不会被移去的石头。稍微分析一下即可发现标志不会向后移动。


#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
const int MAXN=50010;
const int INF =1000000007;
int l,m,n;
int a[MAXN];
bool C(int x){
    int cnt=0;
    int i=0,j=1;
	while(j<=n+1){
        if(a[j]-a[i]<x){
            cnt++;
            j=j+1;
        }
        else{
            i=j;
            j++;
        }
	}
	if(cnt<=m)
        return true;
    else
        return false;
}
int main()
{
	while(scanf("%d%d%d",&l,&n,&m)!=EOF){
		for(int i=1;i<=n;i++){
			scanf("%d",a+i);
		}
		a[0]=0;
		a[n+1]=l;
		sort(a,a+n+1);
		int lb=0,ub=INF;
		while(ub-lb>1){
			int x=(ub+lb)>>1;
			if(C(x)){
				lb=x;
			}
			else
				ub=x;
		}
		printf("%d\n",lb);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值