HYSBZ 1588: [HNOI2002]营业额统计(splay)

46 篇文章 1 订阅
3 篇文章 0 订阅

1588: [HNOI2002]营业额统计

Time Limit: 5 Sec   Memory Limit: 162 MB
Submit: 16609   Solved: 6663
[ Submit][ Status][ Discuss]

Description

营业额统计 Tiger最近被公司升任为营业部经理,他上任后接受公司交给的第一项任务便是统计并分析公司成立以来的营业情况。 Tiger拿出了公司的账本,账本上记录了公司成立以来每天的营业额。分析营业情况是一项相当复杂的工作。由于节假日,大减价或者是其他情况的时候,营业额会出现一定的波动,当然一定的波动是能够接受的,但是在某些时候营业额突变得很高或是很低,这就证明公司此时的经营状况出现了问题。经济管理学上定义了一种最小波动值来衡量这种情况: 该天的最小波动值 当最小波动值越大时,就说明营业情况越不稳定。 而分析整个公司的从成立到现在营业情况是否稳定,只需要把每一天的最小波动值加起来就可以了。你的任务就是编写一个程序帮助Tiger来计算这一个值。 第一天的最小波动值为第一天的营业额。  输入输出要求

Input

第一行为正整数 ,表示该公司从成立一直到现在的天数,接下来的n行每行有一个整数(有可能有负数) ,表示第i
天公司的营业额。
天数n<=32767,
每天的营业额ai <= 1,000,000。
最后结果T<=2^31

Output

输出文件仅有一个正整数,即Sigma(每天最小的波动值) 。结果小于2^31 。

Sample Input

6
5
1
2
5
4
6

Sample Output

12

HINT

结果说明:5+|1-5|+|2-1|+|5-5|+|4-5|+|6-5|=5+4+1+0+1+1=12


该题数据bug已修复.----2016.5.15

Source

[ Submit][ Status][ Discuss]


//splay查找前驱和后继,简单应用

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int INF=0x3f3f3f3f;
const int MAXN=100000+10;

int pre[MAXN],ch[MAXN][2],key[MAXN];//father,lson and rson,keyvalue
int root,tot;//root of the node,total node number

void NewNode(int &r,int fa,int k){
	r=++tot;
	pre[r]=fa;
	ch[r][0]=ch[r][1]=0;
	key[r]=k;
}

void init(){
	root=tot=0;
	ch[root][0]=ch[root][1]=key[root]=pre[root]=0;
}

void rotate(int x,int kind){
	int y=pre[x];
	ch[y][!kind]=ch[x][kind];
	pre[ch[x][kind]]=y;
	if(pre[y])
		ch[pre[y]][ch[pre[y]][1]==y]=x;
	pre[x]=pre[y];
	ch[x][kind]=y;
	pre[y]=x;
}

void splay(int r,int goal){
	while(pre[r]!=goal){
		if(pre[pre[r]]==goal)
			rotate(r,ch[pre[r]][0]==r);
		else{
			int y=pre[r];
			int kind=ch[pre[y]][0]==y;
			if(ch[y][kind]==r){
				rotate(r,!kind);
				rotate(r,kind);
			}else{
				rotate(y,kind);
				rotate(r,kind);
			}
		}
	}
	if(goal==0)
		root=r;
}

void insert(int k){
	int r=root;
	if(r==0){
		NewNode(root,0,k);
		return;
	}
	while(ch[r][key[r]<k]){
		r=ch[r][key[r]<k];
	}
	NewNode(ch[r][key[r]<k],r,k);
	splay(ch[r][key[r]<k],0);
}

int Get_Min(int r){
	while(ch[r][0]){
		r=ch[r][0];
	}
	return r;
}
int Get_Max(int r){
	while(ch[r][1]){
		r=ch[r][1];
	}
	return r;
}

int main(){
	int n;
	scanf("%d",&n);
	init();
	int ans=0;
	for(int i=1;i<=n;i++){
		int x;
		scanf("%d",&x);
		insert(x);
		if(i==1){
			ans+=x;
		}else{
            int tmp=INF;
            if(ch[root][0])
                tmp=min(tmp,key[root]-key[Get_Max(ch[root][0])]);
            if(ch[root][1])
                tmp=min(tmp,key[Get_Min(ch[root][1])]-key[root]);
            ans+=tmp;
		}
	}
	printf("%d\n",ans);
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值