POJ2653 Pick-up sticks(计算几何)

Pick-up sticks
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 13739 Accepted: 5210

Description

Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.

Input

Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.

Output

For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown. 

The picture to the right below illustrates the first case from input.

Sample Input

5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0

Sample Output

Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.

Hint

Huge input,scanf is recommended.


这题的数据范围简直有毒,n^2的算法是可以过的


#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<vector>
#include<algorithm>
#include <iostream>
#include <string>
#include <set>
#include <map>
#include <queue>
using namespace std;
const int MAXN = 500000+10;
const int INF=1e9+7;
const double eps=1e-8;
const double pi=acos(-1.0);
//计算几何误差修正
//输入为一个double类型的数,返回-1表示负数,1表示正数,0表示x为0
int cmp(double x){
    if(fabs(x)<eps)
        return 0;
    if(x>0) return 1;
    return -1;
}

//计算几何点类
inline double sqr(double x){
    return x*x;
}

struct point{
    double x,y;
    point(){}
    point(double a,double b):x(a),y(b){}
    void input(){
        scanf("%lf%lf",&x,&y);
    }
    //加法
    friend point operator + (const point &a,const point &b){
        return point(a.x+b.x,a.y+b.y);
    }
    //减法
    friend point operator - (const point &a,const point &b){
        return point(a.x-b.x,a.y-b.y);
    }
    //判断相等
    friend bool operator == (const point &a,const point &b){
        return cmp(a.x-b.x)==0&&cmp(a.y-b.y)==0;
    }
    //倍增
    friend point operator * (const point &a,const double &b){
        return point(a.x*b,a.y*b);
    }
    //倍增
    friend point operator * (const double &b,const point &a){
        return point(a.x*b,a.y*b);
    }
    //除法
    friend point operator / (const point &a,const double b){
        return point(a.x/b,a.y/b);
    }
    //模长
    double norm(){
        return sqrt(sqr(x)+sqr(y));
    }
};

//叉积,a×b>0代表a在b的顺时针方向,<0代表a在b的逆时针方向,等于0代表a和b向量共线,但不确定方向是否相同
double det(const point &a,const point &b){
    return a.x*b.y-a.y*b.x;
}
//点积
double dot(const point &a,const point &b){
    return a.x*b.x+a.y*b.y;
}
//距离
double dist(const point &a,const point &b){
    return (a-b).norm();
}
//op向量绕原点逆时针旋转A(弧度)
point rotate_point(const point &p,double A){
    double tx=p.x,ty=p.y;
    return point(tx*cos(A)-ty*sin(A),tx*sin(A)+ty*cos(A));
}

//计算几何线段类
struct line{
    point a,b;
    line(){}
    line(point x,point y):a(x),b(y){}
    void input(){
        a.input();
        b.input();
    }
};

//用两个点a,b生成的一个线段或者直线
line point_make_line(point a,point b){
    return line(a,b);
}

//求点p到线段st的距离
double dis_point_segment(point p,point s,point t){
    if(cmp(dot(p-s,t-s))<0) return (p-s).norm();
    if(cmp(dot(p-s,s-t))<0) return (p-t).norm();
    return fabs(det(s-p,t-p)/dist(s,t));
}
//求点p到线段st的垂足,保存在cp中
void PointProjLine(point p,point s,point t,point &cp){
    double r=dot((t-s),(p-s))/dot(t-s,t-s);
    cp=s+(t-s)*r;
}

//判断p点是否在线段st上
bool PointOnSegment(point p,point s,point t){
    return cmp(det(p-s,t-s))==0&&cmp(dot(p-s,p-t))<=0;
}

//判断a和b是否平行
bool parallel(line a,line b){
    return !cmp(det(a.a-a.b,b.a-b.b));
}

//判断a和b是否共线
bool contribution(line a,line b){
    if(!parallel(a, b))
        return false;
    if(!cmp(det(a.b-a.a,b.a-a.b)))
        return true;
    return false;
}

//判断a和b是否相交,若相交则返回true且交点保存在res中
bool line_make_point(line a,line b,point &res){
    if(parallel(a, b))
        return false;
    double s1=det(a.a-b.a,b.b-b.a);
    double s2=det(a.b-b.a,b.b-b.a);
    res=(s1*a.b-s2*a.a)/(s1-s2);
    return true;
}
//判断线段是否相交
bool segment_make_point(line a,line b,point &res){
    if(!line_make_point(a,b,res)&&!PointOnSegment(a.a, b.a, b.b)&&!PointOnSegment(a.b, b.a, b.b))
        return false;
    if(PointOnSegment(res, a.a, a.b)&&PointOnSegment(res, b.a, b.b))
        return true;
    return false;
}
//判断线段和直线是否相交,a是直线,b是线段
bool line_across_segment(line a,line b){
    if(cmp(det(a.b-a.a,b.a-a.a)*det(a.b-a.a,b.b-a.a))==1){
        return false;
    }
    return true;
}

//将直线a沿法向量方向平移距离len得到的直线
line move_d(line a,const double &len){
    point d=a.b-a.a;
    d=d/d.norm();
    d=rotate_point(d, pi/2);
    return line(a.a+d*len,a.b+d*len);
}

line l[MAXN];
int res[MAXN];
int main(){
    int n;
    while(scanf("%d",&n)&&n){
        for(int i=0;i<n;i++)
            l[i].input();
        int tot=0;
        printf("Top sticks: ");
        for(int i=0;i<n;i++){
            int ok=1;
            for(int j=i+1;j<n;j++){
                point temp;
                if(segment_make_point(l[i], l[j], temp)){
                    ok=0;
                    break;
                }
            }
            if(ok)
                res[tot++]=i+1;
        }
        for(int i=0;i<tot;i++){
            printf("%d%s",res[i],i==tot-1?".\n":", ");
        }
    }
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值