Description
YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy's base. After overcoming a series difficulties, YYF is now at the start of enemy's famous "mine road". This is a very long road, on which there are numbers of mines. At first, YYF is at step one. For each step after that, YYF will walk one step with a probability of
p, or jump two step with a probality of 1-
p. Here is the task, given the place of each mine, please calculate the probality that YYF can go through the "mine road" safely.
Input
The input contains many test cases ended with
EOF.
Each test case contains two lines.
The First line of each test case is N (1 ≤ N ≤ 10) and p (0.25 ≤ p ≤ 0.75) seperated by a single blank, standing for the number of mines and the probability to walk one step.
The Second line of each test case is N integer standing for the place of N mines. Each integer is in the range of [1, 100000000].
Each test case contains two lines.
The First line of each test case is N (1 ≤ N ≤ 10) and p (0.25 ≤ p ≤ 0.75) seperated by a single blank, standing for the number of mines and the probability to walk one step.
The Second line of each test case is N integer standing for the place of N mines. Each integer is in the range of [1, 100000000].
Output
For each test case, output the probabilty in a single line with the precision to 7 digits after the decimal point.
Sample Input
1 0.5 2 2 0.5 2 4
Sample Output
0.5000000
0.2500000
思路:
不难想到
dp[i]表示安全地踩在此处的概率。
则如果i处有地雷。dp[i] = 0;
否则dp[i] = dp[i-1]*p + dp[i-2]*(1-p);
规模一亿,目测TLE。。
用矩阵快速幂,不过得分段矩阵快速幂。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct Matrix
{
double a[2][2];
};
Matrix mul(Matrix a,Matrix b)
{
Matrix ret;
for(int i = 0;i < 2;i++)
{
for(int j = 0;j < 2;j++)
{
ret.a[i][j] = 0;
for(int k = 0;k < 2;k++)
ret.a[i][j] += a.a[i][k]*b.a[k][j];
}
}
return ret;
}
Matrix Pow_M(Matrix a,int n)
{
Matrix ret;
memset(ret.a,0,sizeof(ret.a));
for(int i = 0;i < 2;i++) ret.a[i][i] = 1;
Matrix temp = a;
while(n)
{
if(n & 1) ret = mul(ret,temp);
temp = mul(temp,temp);
n >>= 1;
}
return ret;
}
int pos[20];
int main()
{
//freopen("in.txt","r",stdin);
int n;double p;
while(scanf("%d%lf",&n,&p)==2)
{
for(int i = 1;i <= n;i++) scanf("%d",&pos[i]);
sort(pos+1,pos+n+1);
Matrix ans,pp;
ans.a[0][0] = 1;
ans.a[0][1] = 0;
ans.a[1][0] = 0;
ans.a[1][1] = 1;
pp.a[0][0] = p;
pp.a[0][1] = 1;
pp.a[1][0] = 1-p;
pp.a[1][1] = 0;
for(int i = 1;i <= n;i++)
{
Matrix temp;
if(i == 1)
{
temp = Pow_M(pp,pos[i]-1);
}
else
{
temp = Pow_M(pp,pos[i] - pos[i-1]);
}
ans = mul(ans,temp);
ans.a[0][0] = 0;
if(pos[i] == pos[i-1] + 1)
{
memset(ans.a,0,sizeof(ans.a));
break;
}
}
printf("%.7lf\n",ans.a[0][1]*(1-p));
}
return 0;
}