POJ3744-Scout YYF I--概率DP

Description

YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy's base. After overcoming a series difficulties, YYF is now at the start of enemy's famous "mine road". This is a very long road, on which there are numbers of mines. At first, YYF is at step one. For each step after that, YYF will walk one step with a probability of p, or jump two step with a probality of 1- p. Here is the task, given the place of each mine, please calculate the probality that YYF can go through the "mine road" safely.

Input

The input contains many test cases ended with EOF.
Each test case contains two lines.
The First line of each test case is N (1 ≤ N ≤ 10) and p (0.25 ≤ p ≤ 0.75) seperated by a single blank, standing for the number of mines and the probability to walk one step.
The Second line of each test case is N integer standing for the place of N mines. Each integer is in the range of [1, 100000000].

Output

For each test case, output the probabilty in a single line with the precision to 7 digits after the decimal point.

Sample Input

1 0.5
2
2 0.5
2 4

Sample Output

0.5000000

0.2500000

 

思路:

不难想到
dp[i]表示安全地踩在此处的概率。
则如果i处有地雷。dp[i] = 0;
否则dp[i] = dp[i-1]*p + dp[i-2]*(1-p);
规模一亿,目测TLE。。
用矩阵快速幂,不过得分段矩阵快速幂。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct Matrix
{
	double a[2][2];
};

Matrix mul(Matrix a,Matrix b)
{
	Matrix ret;
	for(int i = 0;i < 2;i++)
	{
		for(int j = 0;j < 2;j++)
		{
			ret.a[i][j] = 0;
			for(int k = 0;k < 2;k++)
				ret.a[i][j] += a.a[i][k]*b.a[k][j];
		}
	}
	return ret;
}

Matrix Pow_M(Matrix a,int n)
{
	Matrix ret;
	memset(ret.a,0,sizeof(ret.a));
	for(int i = 0;i < 2;i++)	ret.a[i][i] = 1;
	Matrix temp = a;
	while(n)
	{
		if(n & 1)	ret = mul(ret,temp);
		temp = mul(temp,temp);
		n >>= 1;
	}
	return ret;
}

int pos[20];
int main()
{
	//freopen("in.txt","r",stdin);
	int n;double p;
	while(scanf("%d%lf",&n,&p)==2)
	{
		for(int i = 1;i <= n;i++)	scanf("%d",&pos[i]);
		sort(pos+1,pos+n+1);
		Matrix ans,pp;
		ans.a[0][0] = 1;
		ans.a[0][1] = 0;
		ans.a[1][0] = 0;
		ans.a[1][1] = 1;
		pp.a[0][0] = p;
		pp.a[0][1] = 1;
		pp.a[1][0] = 1-p;
		pp.a[1][1] = 0;
		for(int i = 1;i <= n;i++)
		{
			Matrix temp;
			if(i == 1)
			{
				temp = Pow_M(pp,pos[i]-1);
			}
			else 
			{
				temp = Pow_M(pp,pos[i] - pos[i-1]);
			}
			ans = mul(ans,temp);
			ans.a[0][0] = 0;
			if(pos[i] == pos[i-1] + 1)
			{
				memset(ans.a,0,sizeof(ans.a));
				break;
			}
		}
		printf("%.7lf\n",ans.a[0][1]*(1-p));
	}
	return 0;
}


 

内容概要:该题库专为研究生入学考试计算机组成原理科目设计,涵盖名校考研真题、经典教材课后习题、章节题库和模拟试题四大核心模块。名校考研真题精选多所知名高校的计算机组成原理科目及计算机联考真题,并提供详尽解析,帮助考生把握考研命题趋势与难度。经典教材课后习题包括白中英《计算机组成原理》(第5版)和唐朔飞《计算机组成原理》(第2版)的全部课后习题解答,这两部教材被众多名校列为考研指定参考书目。章节题库精选代表性考题,注重基础知识与重难点内容,帮助考生全面掌握考试大纲要求的知识点。模拟试题依据历年考研真题命题规律和热门考点,精心编制两套全真模拟试题,并附标准答案,帮助考生检验学习成果,评估应试能力。 适用人群:计划参加研究生入学考试并报考计算机组成原理科目的考生,尤其是需要系统复习和强化训练的学生。 使用场景及目标:①通过研读名校考研真题,考生可以准确把握考研命题趋势与难度,有效评估复习成效;②通过经典教材课后习题的练习,考生可以巩固基础知识,掌握解题技巧;③通过章节题库的系统练习,考生可以全面掌握考试大纲要求的各个知识点,为备考打下坚实基础;④通过模拟试题的测试,考生可以检验学习成果,评估应试能力,为正式考试做好充分准备。 其他说明:该题库不仅提供详细的题目解析,还涵盖了计算机组成原理的各个方面,包括计算机系统概述、数据表示与运算、存储器分层、指令系统、中央处理器、总线系统和输入输出系统等。考生在使用过程中应结合理论学习与实践操作,注重理解与应用,以提高应试能力和专业知识水平。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值