POJ2531--Network Saboteur

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.  
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.  
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.  
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).  
Output file must contain a single integer -- the maximum traffic between the subnetworks.  

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90
/*
至多有20个节点
可以用随机化逼近正解
用bool型来标记每个节点所归属的子集
每次随机生成一个节点,改变该节点状态,看最大割是否有更新。不断更新
*/
#include <iostream>
#include <cstdio>
using namespace std;
#define inf 200000
int w[28][28];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				scanf("%d",&w[i][j]);
			}
		}
		int sum=0,maxsum=0;
		bool vis[28]={false};
		for(int i=1;i<=inf;i++)
		{
			int x=rand()%n+1;
			vis[x]=!vis[x];
			for(int j=1;j<=n;j++)
			{
				if(vis[x]!=vis[j])//说明原先他们是属于同一个集合的,现在不属于。所以sum得+ 
				{
					sum+=w[x][j];
				}
			}
			for(int j=1;j<=n;j++)
			{
				if(vis[x]==vis[j])
				{
					sum-=w[x][j];
				}
			}
			if(sum>maxsum)
			{
				maxsum=sum;
			}
		}
		cout<<maxsum<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值