POJ1523--SPF

Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible.

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate.

Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist.

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 1008
int first[maxn],vis[maxn],dfn[maxn],low[maxn],cut[maxn];
int cnt,e,root;
int vv[maxn*10],nxt[maxn*10];
void addEdge(int u,int v)
{
	vv[e] = v;	nxt[e] = first[u];	first[u] = e++;
	vv[e] = u;	nxt[e] = first[v];		first[v] = e++;
}
inline int min(int a,int b)
{
	return a>b?b:a;
}
inline int max(int a,int b)
{
	return a>b?a:b;
}
void Tarjan(int u,int fa)
{
	int child = 0;
	vis[u] = 1;
	dfn[u] = low[u] = ++ cnt;
	for(int i = first[u];i != -1;i = nxt[i])
	{
		int v = vv[i];
		if(vis[v] == 1 && v != fa)
		{
			low[u] = min(low[u],dfn[v]);
		}
		if(vis[v] == 0)
		{
			Tarjan(v,u);
			child++;
			low[u] = min(low[u],low[v]);
			if((u == root && child > 1) || (u != root && dfn[u] <= low[v]))
				cut[u]++;
		}
	}
	vis[u] = 2;
}
int main()
{
	//freopen("in.txt","r",stdin);
	int u,v;
	memset(vis,0,sizeof(vis));
	memset(cut,0,sizeof(cut));
	memset(first,-1,sizeof(first));
	memset(dfn,0,sizeof(dfn));
	int ans = 0,cas = 0,ok = 0;
	while(scanf("%d",&u)!=EOF)
	{
		if(u == 0 && ok) 
		{
			cas++;
			for(int i = 1;i <= 1000;i++)
			{
				if(!dfn[i])
				{
					root = i;
					cnt = 0;
					Tarjan(i,-1);
				}
			}
			printf("Network #%d\n",cas);
			bool flag = false;
			for(int i = 1;i <= 1000;i ++)
			{
				if(cut[i])	
				{
					flag = true;
					printf("  SPF node %d leaves %d subnets\n",i,cut[i]+1);
				}
			}
			if(!flag) printf("  No SPF nodes\n");
			printf("\n");
			ans = e = cnt = ok = 0;
			memset(vis,0,sizeof(vis));
			memset(cut,0,sizeof(cut));
			memset(first,-1,sizeof(first));
			memset(dfn,0,sizeof(dfn));
		}
		else 
		{
			ok++;
			scanf("%d",&v);
			addEdge(u,v);
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧农业是一种结合了现代信息技术,包括物联网、大数据、云计算等,对农业生产过程进行智能化管理和监控的新模式。它通过各种传感器和设备采集农业生产中的关键数据,如大气、土壤和水质参数,以及生物生长状态等,实现远程诊断和精准调控。智慧农业的核心价值在于提高农业生产效率,保障食品安全,实现资源的可持续利用,并为农业产业的转型升级提供支持。 智慧农业的实现依赖于多个子系统,包括但不限于设施蔬菜精细化种植管理系统、农业技术资料库、数据采集系统、防伪防串货系统、食品安全与质量追溯系统、应急追溯系统、灾情疫情防控系统、农业工作管理系统、远程诊断系统、监控中心、环境监测系统、智能环境控制系统等。这些系统共同构成了一个综合的信息管理和服务平台,使得农业生产者能够基于数据做出更加科学的决策。 数据采集是智慧农业的基础。通过手工录入、传感器自动采集、移动端录入、条码/RFID扫描录入、拍照录入以及GPS和遥感技术等多种方式,智慧农业系统能够全面收集农业生产过程中的各种数据。这些数据不仅包括环境参数,还涵盖了生长状态、加工保存、检验检疫等环节,为农业生产提供了全面的数据支持。 智慧农业的应用前景广阔,它不仅能够提升农业生产的管理水平,还能够通过各种应用系统,如库房管理、无公害监控、物资管理、成本控制等,为农业生产者提供全面的服务。此外,智慧农业还能够支持政府监管,通过发病报告、投入品报告、死亡报告等,加强农业产品的安全管理和质量控制。 面对智慧农业的建设和发展,存在一些挑战,如投资成本高、生产过程标准化难度大、数据采集和监测的技术难题等。为了克服这些挑战,需要政府、企业和相关机构的共同努力,通过政策支持、技术创新和教育培训等手段,推动智慧农业的健康发展。智慧农业的建设需要明确建设目的,选择合适的系统模块,并制定合理的设备布署方案,以实现农业生产的智能化、精准化和高效化。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值