POJ3281--Dining

 

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers:   N,   F, and   D  
Lines 2.. N+1: Each line   i  starts with a two integers   Fi  and   Di, the number of dishes that cow   i  likes and the number of drinks that cow   i  likes. The next   Fi  integers denote the dishes that cow   i  will eat, and the   Di  integers following that denote the drinks that cow   i  will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 508
#define edge 50080
#define inf 0x3f3f3f3f
int first[maxn],dis[maxn],num[maxn];
int vv[edge],ww[edge],nxt[edge];
int e,NN;
inline int min(int a,int b)
{
	return a>b?b:a;
}
void addEdge(int u,int v,int w)
{
	vv[e] = v;	ww[e] = w;		nxt[e] = first[u];	first[u] = e++;
	vv[e] = u;	ww[e] = 0;		nxt[e] = first[v];		first[v] = e++;
}
int dfs(int u,int s,int d,int cost)
{
	if(u == d)	return cost;
	int ans = 0;
	int _min = NN;
	for(int i = first[u];i != -1;i = nxt[i])
	{
		int v = vv[i];
		if(ww[i])
		{
			if(dis[v] + 1 == dis[u])
			{
				int t = dfs(v,s,d,min(ww[i],cost));
				ww[i] -= t;
				ww[i^1] += t;
				ans += t;
				cost -= t;
				if(dis[s] == NN)		return ans;
				if(!cost)	break;
			}
			if(_min > dis[v])		_min = dis[v];
		}
	}
	if(!ans)
	{
		if(--num[dis[u]] == 0)	dis[s] = NN;
		dis[u] = _min + 1;
		++num[dis[u]];
	}
	return ans;
}
int isap(int s,int d)
{
	memset(dis,0,sizeof(dis));
	memset(num,0,sizeof(num));
	num[0] = NN;
	int ans = 0;
	while(dis[s] < NN)
		ans += dfs(s,s,d,inf);
	return ans;
}
int main()
{
	//freopen("in.txt","r",stdin);
	int n,f,d;
	while(scanf("%d%d%d",&n,&f,&d)==3)
	{
		memset(first,-1,sizeof(first));
		e = 0;
		NN = 2+f+d+2*n;
		for(int i = 1;i <= f;i++)
		{	
			addEdge(0,i,1);
		}
		for(int i = f+2*n+1;i <= f+2*n+d;i++)
		{
			addEdge(i,f+2*n+d+1,1);
		}
		for(int i = f+1;i <= f+n;i++)
		{
			addEdge(i,i+n,1);
		}
		for(int i = 1;i <= n;i++)
		{
			int ff,dd;		scanf("%d%d",&ff,&dd);
			for(int j = 1;j <= ff;j++)
			{
				int u;	scanf("%d",&u);
				addEdge(u,f+i,1);
			}
			for(int j = 1;j <= dd;j++)
			{
				int v;	scanf("%d",&v);
				addEdge(f+i+n,f+2*n+v,1);
			}
		}
		printf("%d\n",isap(0,f+2*n+d+1));
	}
	return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值