动态规划练习--X()

题目描述:

Description

The whole family was excited by the news. Everyone knew grandpa had been an extremely good bridge player for decades, but when it was announced he would be in the Guinness Book of World Records as the most successful bridge player ever, whow, that was astonishing! 
The International Bridge Association (IBA) has maintained, for several years, a weekly ranking of the best players in the world. Considering that each appearance in a weekly ranking constitutes a point for the player, grandpa was nominated the best player ever because he got the highest number of points. 
Having many friends who were also competing against him, grandpa is extremely curious to know which player(s) took the second place. Since the IBA rankings are now available in the internet he turned to you for help. He needs a program which, when given a list of weekly rankings, finds out which player(s) got the second place according to the number of points.

Input

The input contains several test cases. Players are identified by integers from 1 to 10000. The first line of a test case contains two integers N and M indicating respectively the number of rankings available (2 <= N <= 500) and the number of players in each ranking (2 <= M <= 500). Each of the next N lines contains the description of one weekly ranking. Each description is composed by a sequence of M integers, separated by a blank space, identifying the players who figured in that weekly ranking. You can assume that: 
  • in each test case there is exactly one best player and at least one second best player, 
  • each weekly ranking consists of M distinct player identifiers.

The end of input is indicated by N = M = 0.

Output

For each test case in the input your program must produce one line of output, containing the identification number of the player who is second best in number of appearances in the rankings. If there is a tie for second best, print the identification numbers of all second best players in increasing order. Each identification number produced must be followed by a blank space.

Sample Input

4 5
20 33 25 32 99
32 86 99 25 10
20 99 10 33 86
19 33 74 99 32
3 6
2 34 67 36 79 93
100 38 21 76 91 85
32 23 85 31 88 1
0 0

Sample Output

32 33
1 2 21 23 31 32 34 36 38 67 76 79 88 91 93 100
题目大意:求出现最多的编号的个数

解题思路:

首先找到出现次数最多的编号。然后根据出现次数最多的编号找出现次数第二多的编号。具体参见代码。

源代码:

#include <iostream>
using namespace std;
int player[100001];
int main()
{
    int N,M;
    while (cin>>N>>M)
    {
        memset(player,0,sizeof(player));
        int number,max=0,j,t,flag=0;
        if (N==0&&M==0)
            break;
        for (int i=0;i<N*M;i++) // 求出出现次数最多的编号
        {
            cin>>number;
            player[number]++;
            if (max<player[number])
                max=player[number];
        }
        for (j=max-1;j>=1;j--) // 根据出现次数最多的编号,依次减一,找第二多的。
        {
            for (t=1;t<=10000;t++)
            {
                if (player[t]==j) //找到次数第二多的。输出。
                {
                    flag=1;
                    cout<<t;
                }
                if (flag==1)
                    break;
            }
            if (flag==1)
                break;
        }
        if (flag==1) //输出编号。
            for (t=t+1;t<=10000;t++)
                if (player[t]==j)
                    cout<<" "<<t;
        cout<<endl;
    }
    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值