HDU Problem d-dp

 

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. <br><br>Write a program to find and print the nth element in this sequence<br>

 

 

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.<br>

 

 

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.<br>

 

 

Sample Input

 

1

2

3

4

11

12

13

21

22

23

100

1000

5842

0

 

 

Sample Output

 

The 1st humble number is 1.

The 2nd humble number is 2.

The 3rd humble number is 3.

The 4th humble number is 4.

The 11th humble number is 12.

The 12th humble number is 14.

The 13th humble number is 15.

The 21st humble number is 28.

The 22nd humble number is 30.

The 23rd humble number is 32.

The 100th humble number is 450.

The 1000th humble number is 385875.

The 5842nd humble number is 2000000000.

题意:

生成一组序列,序列里面的每一个元素,分解因子到最后,因子只含有1,2,3,5,7

然后输入一个位置,输出这个位置上的序列元素

思路:

蒟蒻的我只能看了大神的规律

找规律,从1开始,分别乘2 3 5 7,直到计算到第5842的位置

前一个位置上的数,分别乘前一次乘2 或前一次乘3 乘前一次乘5 或前一次乘7 

并寻找其中的最小的(为了不错过任何一个数)

并寻找是乘了那个,将其数加一

具体看代码,最好手推一下运行过程,特别容易理解

code:

#include<iostream>
#include<cstdio>
using namespace std;
int num[6000];
int min(int a,int b,int c,int d)
{
    return min(a,min(b,min(c,d)));
}
void search()
{
    int a,b,c,d;
    a=b=c=d=1;
    num[1]=1;
    for(int i=2;i<=5842;++i)
    {
        //寻找当前的位置的正确的数
        //从小的里面找
        num[i]=min(num[a]*2,num[b]*3,num[c]*5,num[d]*7);
        //下面的是对应上面的,寻找是哪个因子相乘,将这个数加一,继续寻找
        if(num[i]==num[a]*2)
          ++a;
        if(num[i]==num[b]*3)
          ++b;
        if(num[i]==num[c]*5)
          ++c;
        if(num[i]==num[d]*7)
          ++d;
    }
}
int main()
{
    search();
    int n;
    while(scanf("%d",&n)&&n)
    {
        //11 12 13 特殊对待
        printf("The %d",n);
        if(n%10==1&&n%100!=11)
          printf("st");
        else if(n%10==2&&n%100!=12)
               printf("nd");
             else  if(n%10==3&&n%100!=13)
                      printf("rd");
                   else
                     printf("th");
        printf(" humble number is ");
        printf("%d.\n",num[n]);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值