HDU Problem p-dp

 

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …<br>The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

 

Input

The first line contain a integer T , the number of cases.<br>Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

 

Output

One integer per line representing the maximum of the total value (this number will be less than 2<sup>31</sup>).

 

 

Sample Input

 

1

5 10

1 2 3 4 5

5 4 3 2 1

 

 

Sample Output

 

14

题意:

01背包求最大值的模板

一个有确定容量的背包,容量为V;有N件东西,只有放或者不放,求最大价值

第一行有几组测试数据

第二行输入N和V

接下来第一行是价值,下一行是体积

状态转移方程:

dp[j]=max(dp[j],dp[j-s[i].v]+s[i].w);

 

code:

#include<iostream>
#include<cstring>
using namespace std;
struct Bag
{
    int w;//价值
    int v;//体积
}s[1005];
int dp[1005];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(s,0,sizeof(s));
        memset(dp,0,sizeof(dp));
        int N,V;
        cin>>N>>V;
        for(int i=1;i<=N;++i)
           cin>>s[i].w;
        for(int i=1;i<=N;++i)
            cin>>s[i].v;
        for(int i=1;i<=N;++i)
        {
            for(int j=V;j>=s[i].v;--j)
               dp[j]=max(dp[j],dp[j-s[i].v]+s[i].w);
        }
        cout<<dp[V]<<endl;
    }
}

 

 

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值