HDU-problem a

Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. <br><br>We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.<br>
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.<br><br>Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.<br>
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. <br>
 

Sample Input
 
 
3
0 990 692
990 0 179
692 179 0
1
1 2
 

Sample Output
 
 
179

题目大意:

有n的村庄,告诉你每个村庄间的距离,想要修路将所有的村庄连接起来,

问:修路的最短距离是多少?

输入:

第一行 n,表示有多少个村庄

第2行到第n+1行,表示村庄间的距离

接下来一行,表示有q个村庄直间有路,不需要重新修路(即修路距离为0)

接下里q行,每一行表示这两个村庄之间通路

思路:

标准的prim算法,但是别忘了处理两个村庄已经连接的问题

code:

#include<iostream>
#include<string>
using namespace std;
const int maxn=0xfff;
int d[101][101];
int m[101];
bool v[101];
int main()
{
    int n;
    while(cin>>n)
    {
        int x,y;
        for(int i=1; i<=n; ++i)
        {
            m[i]=maxn;
            v[i]=true;
            for(int j=1; j<=n; ++j)
            {
                cin>>d[i][j];
                if(i==j)
                    d[i][j]=maxn;
            }
        }
        int q;
        cin>>q;
        for(int i=1; i<=q; ++i)//表示两个村庄已经连接
        {
            cin>>x>>y;
            d[x][y]=0;
            d[y][x]=0;
        }
        m[1]=0;
        m[0]=maxn;
        for(int i=1; i<=n; ++i)
        {
            int k=0;
            for(int j=1; j<=n; ++j)
                if(v[j]&&(m[j]<m[k]))
                    k=j;
            v[k]=false;
            for(int j=1; j<=n; ++j)
                if(v[j]&&(d[k][j]<m[j]))
                    m[j]=d[k][j];
        }
        int tatal=0;
        for(int i=1; i<=n; ++i)
        {
            tatal+=m[i];
        }
        cout<<tatal<<endl;
    }
    return 0;
}
//完美的代码


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值