Joseph

Problem Description
The Joseph\\\\\\\'s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
 
Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
 
Output

            The output file will consist of separate lines containing m corresponding to k in the input file.
 
Sample Input
3
4
0
 
Sample Output
5
30
 


打表法,关键几行代码理解了就好。
#include <iostream>
using namespace std;
int a[20],i,j,k,n,sum,h,w;
void  init()
{
    for(k=1;k<14;k++)
        for(i=k+1;;i++)
    {
        sum=2*k;
        h=0;
        for(j=i;;j+=i-1)//每次除去的人的位置,从第一个坏人开始,去除间隔是i-1,不懂为什么不是i
        {
            j=j%sum?j%sum:sum;//刚好去掉最后一个人的情况,用自己的编号代替取余结果,否则余数小于K
            if(j<=k)break;
            sum--;
            if(sum==k){
                    h=1;
                break;}

        }
        if(h){
            a[k]=i;
        break;}
    }
}

int main()
{

    init();
    while(cin>>n)
    {
        if(n==0)break;
        cout<<a[n]<<endl;
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值