L - Tri Tiling

L - Tri Tiling

Time Limit:1000MS     MemoryLimit:32768KB     64bit IO Format:%I64d& %I64u

Submit Status Practice HDU 1143

Appoint description: 

Description

In how many wayscan you tile a 3xn rectangle with 2x1 dominoes? Here is a sample tiling of a3x12 rectangle. 

 

Input

Input consistsof several test cases followed by a line containing -1. Each test case is aline containing an integer 0 ≤ n ≤ 30. 

 

Output

For each testcase, output one integer number giving the number of possible tilings. 

 

Sample Input

 2

8

12

-1

 

Sample Output

 3

153

2131

 

import java.util.*;

public class Main {
	
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
		int []a=new int [32];
		a[0]=1;a[1]=0;a[2]=3;a[3]=0;a[4]=11;
	    int i,j,k;
	   for(i=6;i<=31;i+=2){
	        a[i]=a[i-2]*3;
	        k=0;
	        for(j=i-4;j>=0;j-=2)k+=a[j];
	        a[i]=a[i]+2*k;
	        }
		while(in.hasNext()){
		int n=in.nextInt();
		if(n==-1)break;
		System.out.println(a[n]);
		}
		
		}
	}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值