hdu_3407_Zjnu Stadium(带权并查集)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3047

题目大意:求两点之间的相对距离是否满足所给的相对距离,输出不满足条件的个数

题目思路:用带权并查集来记录任意一点与根结点的相对距离

题目:

Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 717    Accepted Submission(s): 296


Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
 

Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

 

Output
For every case:
Output R, represents the number of incorrect request.
 

Sample Input
  
  
10 10 1 2 150 3 4 200 1 5 270 2 6 200 6 5 80 4 7 150 8 9 100 4 8 50 1 7 100 9 2 100
 

Sample Output
 
 
2
#include<iostream>
#include<stdio.h>
using namespace std;
const int size=50005;
int parent[size];
int dist[size];
int n,m;
void init()
{
    for(int i=0; i<=n; ++i)
    {
        parent[i]=i;
        dist[i]=0;
    }
}
int find(int x)
{
    if(x==parent[x]) return parent[x];
    int t=parent[x];
    parent[x] = find(parent[x]);
    dist[x]=(dist[x]+dist[t])%300;
    return parent[x];
}
bool Union(int x,int y,int dd)
{
    int xx=find(x);
    int yy=find(y);
    if(xx==yy)
    {
        if((dist[x]+dd)%300!=dist[y])
            return false;
        return true;
    }
    else
    {
        parent[yy]=xx;
        dist[yy]=(dist[x]+dd-dist[y]+300)%300;
    }
    return true;
}
int main()
{
    int a,b,x;
    int ans;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        ans=0;
        init();
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&a,&b,&x);
            if(!Union(a,b,x))
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值