uva 562 - Dividing coins(注意判断条件,可以转换成01背包做)

1、http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=503

2、题目大意:

给定一个背包,里边有m件硬币,每种硬币的价值给出,现在要将这些硬币分给两个人,让两个人的金钱总数差值尽可能的小,用01背包就能解决,背包较小的那个的最大价值为背包容量的一半

3、题目:


Dividing coins

It's commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.


Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn't stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...


That's what this whole problem is about. Not everyone is capable of seeing instantly what's the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.


Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It's not allowed to split a single coin.

Input

A line with the number of problems n, followed by n times:

  • a line with a non negative integer m ($m \le 100$) indicating the number of coins in the bag
  • a line with m numbers separated by one space, each number indicates the value of a coin.

Output

The output consists of n lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

Sample Input

2
3
2 3 5
4
1 2 4 6

Sample Output

0
1

 4、AC的二维数组的代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 105
int v[N];
int dp[N][25105];
int main()
{
    int t,m,sum;
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            sum=0;
            scanf("%d",&m);
            for(int i=1; i<=m; i++)
            {
                scanf("%d",&v[i]);
                sum+=v[i];
            }
            int ans=sum/2;
            memset(dp,0,sizeof(dp));
            for(int i=1; i<=m; i++)
            {
                for(int j=0; j<=ans; j++)
                { 
//                    if(j-v[i]>=0)
//                        dp[i][j]=max(dp[i-1][j],dp[i-1][j-v[i]]+v[i]);
//这样写是错的,如果当期物品不能装入,那么dp[i][j]就不能选择不装的情况,
//因为if进不去,dp[i][j]就不能得到更新
                    dp[i][j]=dp[i-1][j];
                    if(j-v[i]>=0)
                        dp[i][j]=max(dp[i][j],dp[i-1][j-v[i]]+v[i]);
                        
                       
                }
            }
            //printf("*%d\n",dp[m][ans]);
            int res=sum-2*dp[m][ans];
            printf("%d\n",res);
        }

    }
    return 0;
}


 AC的一维数组的代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 105
int v[N];
int dp[25005];
int main()
{
    int t,m,sum;
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%d",&v[i]);
            sum+=v[i];
        }
        int ans=sum/2;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=m;i++)
        {
            for(int j=ans;j>=0;j--)
            {
                if(j>=v[i])
                dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
            }
        }
        //printf("*%d\n",dp[m][ans]);
        int res=abs(sum-dp[ans]-dp[ans]);
        printf("%d\n",res);
    }
    return 0;
}
/*
2
3
2 3 5
4
1 2 4 6
*/


 

4、代码:二维的dp [][] wrong answer了

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 105
int v[N];
int dp[N][50005];
int main()
{
    int t,m,sum;
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%d",&v[i]);
            sum+=v[i];
        }
        int ans=sum/2+1;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=m;i++)
        {
            for(int j=0;j<=ans;j++)
            {
                if(j-v[i]>=0)
                dp[i][j]=max(dp[i-1][j],dp[i-1][j-v[i]]+v[i]);
            }
        }
        //printf("*%d\n",dp[m][ans]);
        int res=abs(sum-dp[m][ans]-dp[m][ans]);
        printf("%d\n",res);
    }
    return 0;
}


 

改成一维的dp也wrong answer了

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 105
int v[N];
int dp[50005];
int main()
{
    int t,m,sum;
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%d",&v[i]);
            sum+=v[i];
        }
        int ans=sum/2+1;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=m;i++)
        {
            for(int j=ans;j>=0;j--)
            {
                if(j-v[i]>=0)
                dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
            }
        }
        //printf("*%d\n",dp[m][ans]);
        int res=abs(sum-dp[ans]-dp[ans]);
        printf("%d\n",res);
    }
    return 0;
}
/*
2
3
2 3 5
4
1 2 4 6
*/


 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值