hdu 3172 Virtual Friends(简单并查集)

点击打开链接

1.题目大意:

网上交友,计算朋友间都有关系的最多人数,用并查集做,

2,wrong answer的原因:

1、有多组样例

while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        { }

    }

2、超时错在用charchange()给出每个人对应的数字编号,改正方法用map;

3/超时解决方式、find方法进行路径压缩、判断0个关系的情况(不确定)

三、题目:

Virtual Friends
Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2085    Accepted Submission(s): 593


Problem Description
These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends. 

Your task is to observe the interactions on such a website and keep track of the size of each person's network. 

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.
 

Input
Input file contains multiple test cases. 
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase). 
 

Output
Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.
 

Sample Input
1
3
Fred Barney
Barney Betty
Betty Wilma
 

Sample Output
2
3
4
 

Source
University of Waterloo Local Contest 2008.09 
 

Recommend
chenrui


 

四、代码:

#include<stdio.h>
#include<map>
#include<iostream>
using namespace std;
map<string,int> m;
int set[100005];
int num[100005];
int find(int x)
{
    int r=x;
    while(r!=set[r])
    r=set[r];
    int i=x;
    while(i!=r)
    {
        int j=set[i];
        set[i]=r;
        i=j;
    }
    return r;
}
void merge(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
    {
        set[fx]=fy;
        num[fy]+=num[fx];
        printf("%d\n",num[fy]);
    }
    else
    {
        printf("%d\n",num[fy]);
    }
}
int main()
{
    int t;
    char a[25];
    char b[25];
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            int n;
            scanf("%d",&n);
            for(int i=1;i<100005;i++)
            {
                set[i]=i;
                num[i]=1;
            }
            m.clear();
            int ans=1;
            for(int i=1;i<=n;i++)
            {
                scanf("%s%s",a,b);
                if(!m[a])
                {
                    m[a]=ans++;
                }
                if(!m[b])
                {
                    m[b]=ans++;
                }
                merge(m[a],m[b]);
            }
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值