poj 1961 Period (KMP 最短循环节)

1、http://poj.org/problem?id=1961

2、题目大意:

 

给定一个长度为n的字符串s,求它的每个前缀的最短循环节。换句话说,对于每个i(2<=i<=n),求一个最大的整数K>1(如果K存在),使得S的前i个字符组成的前缀是某个字符串重复K次得到的。输出所有存在K的i和对应的K。

比如对于字符串aabaabaabaab, 只有当i=2,6,9,12时K存在,且分别为2,2,3,4

题目的样例解释

给一个长度是n的字符串s,假如我们可以找到一个字符串A,可以使得A循环K次后得到一个字符串B,而B正好是s的前缀,输出B的长度,输出K

例如aaa这个样例,A=a,那么A循环K=2的时候得到的B就是aa,输出2,2

A=a,那么A循环K=3的时候得到的B就是aaa,输出3,3

aabaabaabaab这个有12个字母的样例

当A=a的时候,A循环K=2次得到B=aa,输出2,2

当A=aab的时候,A循环K=2次得到B=aabaab,输出6,2

当A=aab的时候,A循环K=3次得到B=aabaabaab,输出9,3

当A=aab的时候,A循环K=4次得到B=aabaabaabaab,输出12,4

3、只用KMP模板中的求模式值的函数

个数为i/(i-f[i])

4、题目:

B - KMP 最短循环节
Time Limit:3000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4
4、代码:

#include<stdio.h>
#include<string.h>
#define N 1000005
char str[N];
int f[N];
void getFail(char *p, int *f)
{
    int m=strlen(p);
    f[0]=f[1]=0;
    for(int i=1; i<m; ++i)
    {
        int j=f[i];
        while(j && p[i]!=p[j])j=f[j];
        f[i+1] = p[i]==p[j]?1+j:0;
    }
}
int main()
{
    int n,cas=0;
    while(scanf("%d",&n))
    {
        if(n==0)
            break;
        cas++;
        printf("Test case #%d\n",cas);
        getchar();
        memset(str,0,sizeof(str));
        for(int i=0; i<n; i++)
            scanf("%c",&str[i]);
        getFail(str,f);
        for(int i=2; i<=n; i++)
        {

            if(f[i]>0&&i%(i-f[i])==0)
                printf("%d %d\n",i,i/(i-f[i]));
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值