hdu 4565

矩阵快速幂

1、http://acm.hdu.edu.cn/showproblem.php?pid=4565

2、

So Easy!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 187    Accepted Submission(s): 67


Problem Description
  A sequence S n is defined as:

Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate S n.
  You, a top coder, say: So easy!
 


 

Input
  There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 2 15, (a-1) 2< b < a 2, 0 < b, n < 2 31.The input will finish with the end of file.
 


 

Output
  For each the case, output an integer S n.
 


 

Sample Input
  
  
2 3 1 2013 2 3 2 2013 2 2 1 2013
 


 

Sample Output
  
  
4 14 4
 


 

Source
 


 

Recommend
zhoujiaqi2010
 


3、代码:

#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <iostream>
#include<math.h>
using namespace std;
#define ll long long

int aa,b,n,m;

struct matrix
{
    ll a[2][2];
} origin,res;


matrix multiply(matrix x,matrix y)
{
    matrix temp;
    memset(temp.a,0,sizeof(temp.a));
    for(int i=0; i<2; i++)
    {
        for(int j=0; j<2; j++)
        {
            for(int k=0; k<2; k++)
            {
                temp.a[i][j]+=(((x.a[i][k])%m)*((y.a[k][j])%m))%m;
            }
            temp.a[i][j]%=m;
        }
    }
    return temp;
}

void init()
{
    origin.a[0][0]=(2*(aa%m))%m;
    origin.a[0][1]=(b%m-((aa%m)*(aa%m))%m+m)%m;
    origin.a[1][0]=1;
    origin.a[1][1]=0;
    memset(res.a,0,sizeof(res.a));
    res.a[0][0]=res.a[1][1]=1;
}

void calc(int N)
{
    int n=N;
    while(n)
    {
        if(n&1)
            res=multiply(res,origin);
        n>>=1;
        origin=multiply(origin,origin);
    }
    matrix tmp,tmp2;
    tmp2.a[0][0]=(((2*(aa%m)*(aa%m))%m)%m+2*(b%m))%m;

    tmp2.a[0][1]=0;
    tmp2.a[1][0]=(2*(aa%m))%m;
    tmp2.a[1][1]=0;
    if(N==0)
        printf("%lld\n",tmp2.a[0][0]%m);
    else
    {
        tmp=multiply(res,tmp2);
        printf("%lld\n",tmp.a[0][0]%m);
    }
}
int main()
{
    while(cin>>aa>>b>>n>>m)
    {
        if(n==1)
        {
            printf("%lld\n", (ll)ceil((aa*1.0+sqrt(b*1.0))*1.0)%m);
        }
        else
        {
            init();
            calc(n-2);
        }
    }
    return 0;
}
/*
2 3 10 2013
2 3 2 2013
2 2 1 2013
*/



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值