uva 674 - Coin Change 动态规划

1、http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=615

2、题目大意:

现在有五种硬币,面值分别是1,5,10,25,50,现在给定 一个金额值,将其换成以上的硬币,求有多少种换法

3‘、想了好久终究是没有想对状态转移方程

正确的方法应该是:dp[i][j]表示用前j种硬币组成i分钱时的种类数,那么状态转移方程是

dp[i][j]+=DP(i-k*v[j],j-1)

4、题目:


Coin Change

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent.    We want to make changes with these coins for a given amount of money.   


For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin,  two 5-cent coins and one 1-cent   coin,  one  5-cent  coin  and  six  1-cent  coins,  or  eleven  1-cent coins. So  there  are  four  ways of  making  changes  for  11  cents  with  the   above coins.    Note  that  we count  that  there  is  one way of making change  for zero cent.   


Write a program to find the total number of different ways of making  changes  for  any  amount  of  money  in  cents.    Your  program should be able to handle up to 7489 cents.

Input

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input

11
26

Sample Output

4
13

5、ac代码:

 

//dp[i][j]表示用前j种硬币组成i分的种类数
#include<stdio.h>
#include<string.h>
#define N 7500
int dp[N][6];
int v[5]={1,5,10,25,50};
int DP(int i,int j)
{
    if(j==0)
    return dp[i][j]=1;
    if(dp[i][j]!=-1)
    return dp[i][j];
    dp[i][j]=0;
    for(int k=0;i-k*v[j]>=0;k++)
    {
        dp[i][j]+=DP(i-k*v[j],j-1);
    }
    return dp[i][j];
}
int main()
{
    int n;
    memset(dp,-1,sizeof(dp));//memset只需初始一次即可,如果后边n很大,可以用之前存好的dp[][]
    while(scanf("%d",&n)!=EOF)
    {  //memset(dp,-1,sizeof(dp));//如果每次都初始化,那么每次都会从头算,会超时
        for(int i=0;i<=n;i++)
        dp[i][0]=1;
        printf("%d\n",DP(n,4));
    }
    return 0;
}


 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值