字符匹配KMP(1)

Number Sequence

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 6   Accepted Submission(s) : 3
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1
 
 
 
题意:求第一个串中完全匹配第二个串开始的位置。
思路:数据较大,需用kmp算法,并且输入 输出用scanf与printf,否则也会TLE。
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<memory.h>
using namespace std;
int a[1000005],b[10005],next[10005];
void getNext(int m)//next[i]表示以b[i]为后缀和前缀的匹配的最大个数
{
    memset(next,0,sizeof(next));
    for(int i=1; i<m; i++)
    {
        int tmp=next[i-1];
        while(tmp&&b[tmp]!=b[i])
            tmp=next[tmp-1];
        if(b[tmp]==b[i])
            next[i]=tmp+1;
        else
            next[i]=0;
    }
}
int kmp(int n,int m)
{
    int j=0;
    for(int i=0; i<n; i++)
    {
        while(j>0&&a[i]!=b[j])
            j=next[j-1];
        if(a[i]==b[j])
            j++;
        else
            j=0;
        if(j==m)//j表示到达i位置两个串匹配的个数
            return i-m+2;
    }
    return -1;
}
int main()
{
    int t,m,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        for(int i=0; i<m; i++)
            scanf("%d",&b[i]);
        getNext(m);
        int j=kmp(n,m);
        printf("%d\n",j);
    }
    return 0;
}
/*
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
*/

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值