字符串4 统计难题

统计难题

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131070/65535K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 2
Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

Sample Input
  
  
banana band bee absolute acm ba b band abc
 

Sample Output
  
  
2 3 1 0
 

Author
Ignatius.L
 

题意:给出一个字典表,即给出一些字符串。然后再给出一些字符串,问字典表内有多少个是以此开头的单词。

思路:字典树。建树的过程就是26个字母做孩子,n记录通过此串的个数。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
using namespace std;
struct dictree
{
    struct dictree *child[27];
    int n;
};
struct dictree *root;
void insert(char *str)
{
    int len;
    len=strlen(str);
    struct dictree *current,*newnode;
    if(len==0) return;
    current=root;
    for(int i=0;i<len;i++)
    {
        if(current->child[str[i]-'a']!=0)
        {
            current=current->child[str[i]-'a'];
            current->n=current->n+1;
        }
        else
        {
            newnode=(struct dictree *)malloc(sizeof(struct dictree));
            for(int j=0;j<26;j++)
            newnode->child[j]=0;
            current->child[str[i]-'a']=newnode;
            current=newnode;
            current->n=1;
        }
    }
}
int find(char *str)
{
    int len;
    struct dictree *current;
    len=strlen(str);
    current=root;
    for(int i=0;i<len;i++)
    {
        if(current->child[str[i]-'a']!=0)
        current=current->child[str[i]-'a'];
        else
        return 0;
    }
    return current->n;
}
int main()
{
    char str[11];
    root=(struct dictree *)malloc(sizeof(struct dictree));
    for(int i=0;i<26;i++)
    root->child[i]=0;
    root->n=2;
    while(gets(str))
    {
        if(strcmp(str,"")==0)break;
        insert(str);
    }
    while(scanf("%s",str)!=EOF)
    {
        printf("%d\n",find(str));
    }
    return 0;
}
/*
banana
band
bee
absolute
acm

ba
b
band
abc
*/



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值