最短路 1006

Minimum Transport Cost

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 7   Accepted Submission(s) : 2
Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
  
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
  
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17 题意:给定一个无向图,-1表示无法到达。另外经过一些城要收税。给定起点和终点。求最小花费和路径。
思路:floy。
#include<iostream>
#include<stdio.h>
#include<string.h>
#define inf 999999999
using namespace std;
int map[1005][1005],cost[1005];
int path[1005][1005];
int n;
void floy()
{
    for(int k=1; k<=n; k++)
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
            {
                if(map[i][j]>map[i][k]+map[k][j]+cost[k])
                {
                    map[i][j]=map[i][k]+map[k][j]+cost[k];//经过k点
                    path[i][j]=path[i][k];
                }
                else if(map[i][j]==map[i][k]+map[k][j]+cost[k])
                {
                    if(path[i][j]>path[i][k])//比较选小的,题目要求选择小的输出
                        path[i][j]=path[i][k];
                }
            }
}
int main()
{
    int st,end;
    while(scanf("%d",&n),n)
    {
       for(int i=1;i<=n;i++)
       for(int j=1;j<=n;j++)
       {
           path[i][j]=j;
           cin>>map[i][j];
           if(map[i][j]==-1)
           map[i][j]=inf;
       }
       for(int i=1;i<=n;i++)
       cin>>cost[i];
       floy();
       while(cin>>st>>end)
       {
           if(st==-1&&end==-1)break;
           int s=st;
           int e=end;
           printf("From %d to %d :\n",s,e);
           printf("Path: %d",s);

           while(st!=end)//输出路径
           {
               printf("-->%d",path[st][end]);
               st=path[st][end];
           }
           cout<<endl;
           printf("Total cost : %d\n\n",map[s][e]);
       }
    }
    return 0;
}
/*
5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0
*/

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值