hdu 1497

Simple Library Management System

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1149    Accepted Submission(s): 333


Problem Description
After AC all the hardest problems in the world , the ACboy 8006 now has nothing to do . One day he goes to an old library to find a part-time job .It is also a big library which has N books and M users.The user's id is from 1 to M , and the book id is from 1 to N . According to the library rules , every user are only allowed to borrow 9 books .But what surprised him is that there is no computer in the library , and everything is just recorded in paper ! How terrible , I must be crazy after working some weeks , he thinks .So he wants to change the situation .

In the other hand , after 8006's fans know it , they all collect money and buy many computers for the library .

Besides the hardware , the library needs a management program . Though it is just a piece of cake for 8006 , the library turns to you , a excellent programer,for help .

What they need is just a simple library management program . It is just a console program , and have only three commands : Borrow the book , Return the book , Query the user .

1.The Borrow command has two parameters : The user id and the book id
The format is : "B ui bi" (1<=ui<=M , 1<=bi<=N)
The program must first check the book bi wether it's in the library . If it is not , just print "The book is not in the library now" in a line . 
If it is , then check the user ui .
If the user has borrowed 9 books already, print "You are not allowed to borrow any more" .
Else let the user ui borrow the book , and print "Borrow success".

2.The Return command only has one parameter : The book id
The format is : "R bi" (1<=bi<=N)
The program must first check the book bi whether it's in the library . If it is , just print "The book is already in the library" . Otherwise , you can return the book , and print "Return success".

3.The Query command has one parameter : The user id
The format is : "Q ui" (1<=ui<=M)
If the number of books which the user ui has borrowed is 0 ,just print "Empty" , otherwise print the books' id which he borrows in increasing order in a line.Seperate two books with a blank.
 

Input
The input file contains a series of test cases . Please process to the end of file . The first line contains two integers M and N ( 1<= M <= 1000 , 1<=N<=100000),the second line contains a integer C means the number of commands(1<=C<=10000). Then it comes C lines . Each line is a command which is described above.You can assum all the books are in the library at the beginning of each cases.
 

Output
For each command , print the message which described above .
Please output a blank line after each test.
If you still have some questions , see the Sample .
 

Sample Input
  
  
5 10 9 R 1 B 1 5 B 1 2 Q 1 Q 2 R 5 Q 1 R 2 Q 1 5 10 9 R 1 B 1 5 B 1 2 Q 1 Q 2 R 5 Q 1 R 2 Q 1
 

Sample Output
  
  
The book is already in the library Borrow success Borrow success 2 5 Empty Return success 2 Return success Empty The book is already in the library Borrow success Borrow success 2 5 Empty Return success 2 Return success Empty
Hint
Hint
Huge input, the function scanf() may work better than cin
 
简单的模拟题,吃回车。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int book[100005];
struct node
{
    int have[10];
    int sum;
} p[1005];
int main()
{
    int n,m,b,u;
    char a;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(book,0,sizeof(book));
        for(int i=0; i<=n; i++)
        {
            p[i].sum=0;
        }
        int t;
        scanf("%d",&t);
        getchar();
        while(t--)
        {
            scanf("%c",&a);
            if(a=='B')
            {
                scanf("%d%d",&u,&b);
                getchar();
                if(book[b])
                    printf("The book is not in the library now\n");
                else if(p[u].sum>=9)
                    printf("You are not allowed to borrow any more\n");
                else
                {
                    p[u].have[p[u].sum++]=b;
                    book[b]=u;
                    printf("Borrow success\n");
                }
            }
            else if(a=='R')
            {
                scanf("%d",&b);
                getchar();
                if(!book[b])
                    printf("The book is already in the library\n");
                else
                {
                    int poit;
                    u=book[b];
                    book[b]=0;
                    for(int i=0; i<p[u].sum; i++)
                        if(p[u].have[i]==b)
                        {
                            poit=i;
                            break;
                        }
                    for(int i=poit; i<p[u].sum-1; i++)
                    {
                        p[u].have[i]=p[u].have[i+1];
                    }
                    p[u].sum--;
                    printf("Return success\n");
                }
            }
            else if(a=='Q')
            {
                scanf("%d",&u);
                getchar();
                if(p[u].sum==0)
                    printf("Empty\n");
                else
                {
                    int b[10];
                    for(int i=0; i<p[u].sum; i++)
                    {
                        b[i]=p[u].have[i];
                    }
                    sort(b,b+p[u].sum);
                    for(int i=0;i<p[u].sum;i++)
                    {
                        if(i==0)
                            printf("%d",b[i]);
                        else
                            printf(" %d",b[i]);
                    }
                    printf("\n");
                }
            }

        }
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值