POJ 1845 --Sumdiv 约数基本定理+乘法逆元

Description

Consider two natural numbers A and B. Let S be the sum of all natural divisors of A^B. Determine S modulo 9901 (the rest of the division of S by 9901).

Input

The only line contains the two natural numbers A and B, (0 <= A,B <= 50000000)separated by blanks.

Output

The only line of the output will contain S modulo 9901.

Sample Input

2 3

Sample Output

15

Hint

2^3 = 8.
The natural divisors of 8 are: 1,2,4,8. Their sum is 15.
15 modulo 9901 is 15 (that should be output).


题目大意:给你两个整数A,B。然后求A^B的所有约数的和。

题目解析:根据约数基本定理如何一个自然数都可以分解为A=(a1^n1)*(a2^n2)*(a3^n3)...(am^nm) 的形式,其中a1,a2,a3......为质数。所有约数的个数为(a1+1)*(a2+1).....*(am+1).而所有约数的和为(a1^0+a1^1+a1^2……a1^n1)*(a2^0+a2^1+a2^2……a2^n2)……*(am^0+am^1+am^2……am^nm)

然后就可以根据等比数列求每一项的和然后相乘   即(a1^(n1+1)-1)/(a1-1) mod 9901  根据前面逆元的知识:a/b mod c = (a mod (b*c))/ b就可以得到  (a1^(n1+1)-1)mod (9901*(a1-1)) / (a1-1)。

AC代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
typedef long long LL;
const int N=10005;
const int MOD=9901;

bool prime[N];
int p[N];
int cnt;

void isprime()
{
	cnt=0;
	memset(prime,true,sizeof(prime));
	for(int i=2;i<N;i++)
	{
		if(prime[i])
		{
			p[cnt++]=i;
			for(int j=i+i;j<N;j+=i)
			{
				prime[j]=false;
			}
		}
	}
}

LL multi(LL a,LL b,LL m)
{
	LL ans=0;
	a%=m;
	while(b)
	{
		if(b&1)
		{
			ans=(ans+a)%m;
			b--;
		}
		b>>=1;
		a=(a+a)%m;
	}
	return ans;
}

LL quick_mod(LL a,LL b,LL m)
{
	LL ans=1;
	a%=m;
	while(b)
	{
		if(b&1)
		{
			ans=multi(ans,a,m);
			b--;
		}
		b>>=1;
		a=multi(a,a,m);
	}
	return ans;
}

void Solve(LL A,LL B)
{
	LL ans=1;
	for(int i=0;p[i]*p[i]<=A;i++)
	{
		if(A%p[i]==0)
		{
			int num=0;
			while(A%p[i]==0)
			{
				num++;
				A/=p[i];
			}
			LL M=(p[i]-1)*MOD;
			ans*=(quick_mod(p[i],num*B+1,M)-1)/(p[i]-1);
			ans%=MOD;
		}
	}
	if(A>1)
	{
		LL M=MOD*(A-1);
		ans*=(quick_mod(A,B+1,M)-1)/(A-1);
		ans%=MOD;
	}
	cout<<ans<<endl;
}

int main()
{
	LL A,B;
	isprime();
	while(cin>>A>>B)
	{
		Solve(A,B);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值