相加和最大值 oj

相加和最大值

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
输入三个整数a,b,c。并进行两两相加,最后比较相加和的最大值。
Input
输入数据包含三个整数,用空格分开。
Output
输出两两相加后的最大值。
Example Input
1 2 3
Example Output
5
 
 
#include <stdio.h>
#include <stdlib.h>

int main()
{
    int a,b,c,d,e,f;
    scanf("%d %d %d",&d,&e,&f);
    a = d + e;
    b = d + f;
    c = e + f;
    if(a < b)
    {
        if(b < c){
            printf("%d",c);
            }else{
            printf("%d",b);
    }}
    else{
         if(a < c){
            printf("%d",c);
            }else{
            printf("%d",a);
    }

    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值