数据结构实验之栈与队列四:括号匹配oj

数据结构实验之栈与队列四:括号匹配

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description

 给你一串字符,不超过50个字符,可能包括括号、数字、字母、标点符号、空格,你的任务是检查这一串字符中的( ) ,[ ],{ }是否匹配。

 

Input

 输入数据有多组,处理到文件结束。

 

Output

 如果匹配就输出“yes”,不匹配输出“no”

 

Example Input
sin(20+10)
{[}]
Example Output
yes
no
Hint
Author
ma6174
#include <stdio.h>
#include <string.h>

int main()
{
    int n,i,flag,top;
    char a[60],s[60];
    while(gets(a))
    {
        n = strlen(a);
        s[0]='+';
        top = 1;
        for(i = 0;i < n;i++)
        {
            if(a[i]=='('||a[i]=='{'||a[i]=='[')
            {
                s[top] = a[i];
                top++;
            }
            else
            {
                if(a[i] == ']')
                {
                    if(s[top-1] == '[')
                        top--;
                    else
                    {
                        s[top-1] = '1';
                        break;
                    }
                }
                if(a[i] == '}')
                {
                    if(s[top-1] == '{')
                        top--;
                    else
                    {
                        s[top-1] = '1';
                        break;
                    }
                }
                if(a[i] == ')')
                {
                    if(s[top-1] == '(')
                        top--;
                    else
                    {
                        s[top-1] = '1';
                        break;
                    }
                }
            }
        }
        if(s[top-1]=='+')
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值