数据结构实验之查找一:二叉排序树oj

数据结构实验之查找一:二叉排序树

Time Limit: 400MS Memory Limit: 65536KB
Problem Description

对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。

Input

输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。
简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。

Output

对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出"Yes",否则输出"No"。

Example Input
4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0
Example Output
Yes
No
No
Hint
 
Author
xam
#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *l,*r;
};
int a[11],b[11],aa[11],bb[11],k;
struct node *creat(struct node *root,int x)
{
    if(root == NULL)
    {
        root = (struct node *)malloc(sizeof(struct node));
        root->data = x;
        root->l = NULL;
        root->r = NULL;
    }
    else
    {
        if(x < root->data)
            root->l = creat(root->l,x);
        else
            root->r = creat(root->r,x);
    }
    return root;
}
int cmptree(struct node *r1,struct node *r2)
{
	if(r1==NULL &&r2==NULL)
	{
		return 1;
	}
	else if(r1==NULL || r2==NULL)
	{
		return 0;
	}
	if(r1->data!=r2->data)
	{
		return 0;
	}
	if(cmptree(r1->l,r2->l)&&cmptree(r1->r,r2->r))
	{
		return 1;
	}
	return 0;
}
int main()
{
    int N,L,i,j,x;
    while(scanf("%d%d",&N,&L) != EOF&&N)
    {
        struct node *root = NULL;
        for(i=0;i<N;i++)
		{
			scanf("%d",&x);
			root = creat(root,x);
		}
		while(L--)
		{
			struct node *p1 = NULL;
			for(i=0;i<N;i++)
			{
				scanf("%d",&a[i]);
				p1 = creat(p1,a[i]);
			}
			if(cmptree(p1,root))
			{
				printf("Yes\n");
			}
			else
			{
				printf("No\n");
			}
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值