(POJ 1002) 487-3279

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 
D, E, and F map to 3 
G, H, and I map to 4 
J, K, and L map to 5 
M, N, and O map to 6 
P, R, and S map to 7 
T, U, and V map to 8 
W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates. 

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

Source


*********************************************************************************************************

*********************************************************************************************************

/* 下面代码使用的方法:计数思想, 每一个标准号码对应一个7位数字, 分配10^7位的数组存储每个标准号码的计数,
   方法简单,思想直白, 不足:空间和时间复杂度较大(对于目录较大的情况,应该是最优的, 但目录不是很大时, 不最优) */


/* 改进1: 排序思想 */
/* 改进2: hash链表, hashcode位数 <= 7,
          从本质来讲, 下面代码的方法相当于一种hash方法,hash表长度为10^7,hash函数为号码对应的7位数字 */
/*
 */

#include <iostream>
#include <iomanip>


using namespace std;


namespace my_phone { //下面的变量写在类中就更好了
const long g_max_directory_number =  10000000;
const int  g_max_phone_length     =  128;
const char g_code[26]             = { '2', '2', '2',
 '3', '3', '3',
 '4', '4', '4',
 '5', '5', '5',
 '6', '6', '6',
 '7', '0', '7', '7',
 '8', '8', '8',
 '9', '9', '9', '0' };
const int g_low_number        = 10000;
const int g_low_digit_number  = 4;
const int g_high_digit_number = 3;
}


int ProcessPhoneNumber() {
//初始化
long *count = new long[ my_phone::g_max_directory_number ];
for (int i =0; i < my_phone::g_max_directory_number; ++i)
*(count + i) = 0;
//输入准备
int dir_len;
char *number = new char[ my_phone::g_max_phone_length];

cin >> dir_len;
long formal_number = 0;
for (int j = 0; j < dir_len; ++j) {
cin >> number;
//对每一个输入号码处理
for (int k = 0; '\0' != number[k]; ++k) {
if (number[k] >= '0' && number[k] <= '9') {
formal_number = 10 * formal_number + number[k] - '0';
} else if (number[k] >= 'A' && number[k] <= 'Z') {
formal_number = 10 * formal_number + my_phone::g_code[ number[k] - 'A' ] - '0';
} else {
}
}
++count[formal_number];  //对应的标准号码出现次数+1
formal_number = 0; //重置标准号码为0
}


//输出
bool has_duplicate = false;
for (int p =0; p < my_phone::g_max_directory_number; ++p) {
if (count[p] > 1) {
has_duplicate = true;
int low_digit  = p % my_phone::g_low_number;
int high_digit = p / my_phone::g_low_number;
cout << setiosflags(ios::right) << setw(my_phone::g_high_digit_number) << setfill('0') << high_digit << '-' 
<< setiosflags(ios::right) << setw(my_phone::g_low_digit_number)  << setfill('0') << low_digit  << ' '
<< count[p] << endl;
}
}


if(!has_duplicate) {
cout << "No duplicates." << endl;
}

delete []number;
delete []count;


return 0;
}
int main() {
ProcessPhoneNumber();
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值