HDU 5170 GTY's math problem

取对数比较就好了log(a^b )=b*log(a) ,注意会有精度误差...

 

GTY's math problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 456    Accepted Submission(s): 212


Problem Description
GTY is a GodBull who will get an Au in NOI . To have more time to learn algorithm knowledge, he never does his math homework. His math teacher is very unhappy for that, but she can't do anything because GTY can always get a good mark in math exams. One day, the math teacher asked GTY to answer a question. There are four numbers on the blackboard - a,b,c,d . The math teacher wants GTY to compare ab with cd . Because GTY never does his homework, he can't figure out this problem! If GTY can't answer this question correctly, he will have to do his homework. So help him!
 


 

Input
Multi test cases (about 5000). Every case contains four integers a,b,c,d( 1a,b,c,d1000 )separated by spaces. Please process to the end of file.
 


 

Output
For each case , if ab>cd , print '>'. if ab<cd , print '<'. if ab=cd , print '='.
 


 

Sample Input
  
  
2 1 1 2 2 4 4 2 10 10 9 11
 


 

Sample Output
  
  
> = <

 

 

AC代码;

#include "stack"
#include "cstdio"
#include "iostream"
#include "cmath"
#include "set"
#include "sstream"
#include "cctype"
#include "string"
#include "cstring"
#include "algorithm"
#include "queue"
#include "map"
using namespace std;
#define LL long long
#define inf 0x7ffffff
#define pa pair<int,int>
#define pi 3.1415926535897932384626433832795028841971

const int M=55;

int main()
{
	double a,b,c,d;
	while(cin>>a>>b>>c>>d)
	{
		double p,s1,s2;
		p=log(a)/log(c);
		b=p*b;
		s1=b;s2=d;
		if(s1-s2<0.00001&&s1-s2>-0.00001)
		   cout<<"=\n";
	    else if(s1<s2)
		   cout<<"<\n";
		else
		   cout<<">\n";  
		
	}
	return 0;
	
	
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值