2-8 符号配对 (20 分)

2-8 符号配对 (20 分)

请编写程序检查C语言源程序中下列符号是否配对:/**/()[]{}

输入格式:

输入为一个C语言源程序。当读到某一行中只有一个句点.和一个回车的时候,标志着输入结束。程序中需要检查配对的符号不超过100个。

输出格式:

首先,如果所有符号配对正确,则在第一行中输出YES,否则输出NO。然后在第二行中指出第一个不配对的符号:如果缺少左符号,则输出?-右符号;如果缺少右符号,则输出左符号-?

输入样例1:

void test()
{
    int i, A[10];
    for (i=0; i<10; i++) { /*/
        A[i] = i;
}
.

输出样例1:

NO
/*-?

输入样例2:

void test()
{
    int i, A[10];
    for (i=0; i<10; i++) /**/
        A[i] = i;
}]
.

输出样例2:

NO
?-]

输入样例3:

void test()
{
    int i
    double A[10];
    for (i=0; i<10; i++) /**/
        A[i] = 0.1*i;
}
.

代码:

#include <iostream>
#include <stack>
#include <map>
using namespace std;
int main()
{
    string str;
    getline(cin,str);
    stack<char> st;
    map<char,char>mp;
    mp[')'] ='(';
    mp[']'] ='[';
    mp['}'] ='{';
    mp['!'] ='?';
    while(str[0]!='.')
    {
        for(int i =0 ; i < str.size(); i ++)
        {
            char ch = str[i];
            if(i+1 < str.size()&& str[i]=='/'&& str[i+1]=='*')
            {
                i++;
                ch = '?';
            }
            else if(i+1 < str.size()&& str[i]=='*'&& str[i+1]=='/')
            {
                i++;
                ch = '!';
            }
            if(mp.count(ch))
            {
                if(st.size()==0)
                {
                    cout<< "NO" << endl;
                    if(ch=='!')
                        cout<<"?-*/"<<endl;
                    else
                        cout<<"?-"<<ch<<endl;
                    return 0;
                }
                else if(mp[ch]!=st.top())
                {
                    cout<< "NO" << endl;
                    if(st.top()=='?')
                        cout<<"/*-?"<<endl;
                    else
                        cout<<st.top()<<"-?"<<endl;
                    return 0;
                }
                st.pop();
            }
            else
            {
                if(ch=='('||ch=='{'||ch=='['||ch=='?')
                    st.push(ch);
            }

        }
       
    }
    if(st.size()==0)
    {
        cout<< "YES" ;
    }
    else
    {
        cout<< "NO" << endl;
        if(st.top()=='?')
            cout<<"/*-?"<<endl;
        else
            cout<<st.top()<<"-?"<<endl;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

追寻远方的人

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值