P1353 [USACO08JAN]跑步Running

题目描述:

The cows are trying to become better athletes, so Bessie is running on a track for exactly N (1 ≤ N ≤ 10,000) minutes. During each minute, she can choose to either run or rest for the whole minute.

The ultimate distance Bessie runs, though, depends on her ‘exhaustion factor’, which starts at 0. When she chooses to run in minute i, she will run exactly a distance of Di (1 ≤ Di ≤ 1,000) and her exhaustion factor will increase by 1 – but must never be allowed to exceed M (1 ≤ M ≤ 500). If she chooses to rest, her exhaustion factor will decrease by 1 for each minute she rests. She cannot commence running again until her exhaustion factor reaches 0. At that point, she can choose to run or rest.

At the end of the N minute workout, Bessie’s exaustion factor must be exactly 0, or she will not have enough energy left for the rest of the day.

Find the maximal distance Bessie can run.

奶牛们打算通过锻炼来培养自己的运动细胞,作为其中的一员,贝茜选择的运动方式是每天进行N(1 <= N <= 10,000)分钟的晨跑。在每分钟的开始,贝茜会选择下一分钟是用来跑步还是休息。

贝茜的体力限制了她跑步的距离。更具体地,如果贝茜选择在第i分钟内跑步,她可以在这一分钟内跑D_i(1 <= D_i <= 1,000)米,并且她的疲劳度会增加1。不过,无论何时贝茜的疲劳度都不能超过M(1 <= M <= 500)。如果贝茜选择休息,那么她的疲劳度就会每分钟减少1,但她必须休息到疲劳度恢复到0为止。在疲劳度为0时休息的话,疲劳度不会再变动。晨跑开始时,贝茜的疲劳度为0。

还有,在N分钟的锻炼结束时,贝茜的疲劳度也必须恢复到0,否则她将没有足够的精力来对付这一整天中剩下的事情。

请你计算一下,贝茜最多能跑多少米。

输入输出格式
输入格式:
第1行: 2个用空格隔开的整数:N 和 M

第2…N+1行: 第i+1为1个整数:D_i

输出格式:
输出1个整数,表示在满足所有限制条件的情况下,贝茜能跑的最大距离

输入输出样例:
输入样例#1:
5 2
5
3
4
2
10
输出样例#1:
9
说明
【样例说明】

贝茜在第1分钟内选择跑步(跑了5米),在第2分钟内休息,在第3分钟内跑步(跑了4米),剩余的时间都用来休息。因为在晨跑结束时贝茜的疲劳度必须为0,所以她不能在第5分钟内选择跑步

注意点:

在疲劳度不为0时,只存在+或-的情况, 一旦-,疲劳度必须归0后才能继续跑(程序里体现)
在疲劳度为0时,则疲劳度可以不变或+
定义dp[i][j]:第i分钟疲劳度为j时已经跑的最大距离

代码:

#include<cstdio>
#include<iostream>
#include <cmath>
#include <algorithm>
using namespace std;
int n,m; int a[10001],dp[10501][501];//10501:i(<=10000)+j(<=500)
inline int MAX(int g1,int g2){
    return g1>=g2?g1:g2;
}
inline int MIN(int g1,int g2){
    return g1<=g2?g1:g2;
}
int main(){
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;++i)
        scanf("%d",a+i);
    for(int i=1;i<=n;++i){//第i分钟 
        dp[i][0]=MAX(dp[i][0],dp[i-1][0]);//某刻休息,dp[i][0]已有值:也可从上分钟继续休息 
        for(int j=1;j<=MIN(i,m);++j){//缩小范围 
            dp[i][j]=dp[i-1][j-1]+a[i];//第一点 
            dp[i+j][0]=MAX(dp[i+j][0],dp[i][j]);//第一点 
        }
    }
    printf("%d",dp[n][0]);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值