数据结构基础:逆波兰式转换

题目:点击打开链接
数据结构实验之栈二:一般算术表达式转换成后缀式
Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
对于一个基于二元运算符的算术表达式,转换为对应的后缀式,并输出之。
Input
输入一个算术表达式,以‘#’字符作为结束标志。
Output
输出该表达式转换所得到的后缀式。
Example Input


a*b+(c-d/e)*f#


Example Output


ab*cde/-f*+

Hint
 
Author
   代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<stack>
using namespace std;
stack <int> s;
int main()
{
    int i;
    char c[1000];
    gets(c);
    while(!s.empty()){
        s.pop();
    }
    for(i=0;c[i]!='#';i++){
        if(c[i]>='a'&&c[i]<='z'){///不是运算符直接输出
            printf("%c",c[i]);
        }
        else{
            if(c[i]=='(')      ///括号之间的运算符保留在栈中
                s.push(c[i]);
            else if(c[i]==')'){         ///输出括号之间的内容
                while(s.top()!='('){
                    printf("%c",s.top());
                    s.pop();
                }
                s.pop();
            }
            else if(c[i]=='+'||c[i]=='-'){///空栈时进栈,否则弹栈直到空栈或弹完括号之间内容
                while(!s.empty()){
                    if(s.top()=='(')
                       break;
                    printf("%c",s.top());
                    s.pop();
                }
                s.push(c[i]);
            }
            else if(c[i]=='*'||c[i]=='/'){  ///乘除号直接进栈
                s.push(c[i]);
            }
        }


        }
        while(!s.empty()){  ///遍历结束,弹完剩余在栈中的内容
            printf("%c",s.top());
            s.pop();
        }
        cout<<endl;
    return 0;
}











革命尚为成功! 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值