二叉树练习——建树+叶子数+深度

数据结构实验之二叉树的建立与遍历

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
       已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后序方式遍历二叉树,最后求出叶子节点个数和二叉树深度。

Input
  输入一个长度小于50个字符的字符串。
Output
输出共有4行:
第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。
Example Input
abc,,de,g,,f,,,
Example Output
cbegdfacgefdba35
Hint
 
Author
 ma6174    


代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
typedef struct Tree{
    char d;
    struct Tree *l,*r;
}Tree;
char s[10005];
int lea,de;
void Creat(Tree *&T){
    char x;
    cin>>x;
    if(x==','){
        T=NULL;
        return;
    }
    else{
        T=new Tree;
        T->d=x;
        Creat(T->l);
        Creat(T->r);
    }
}
void order(Tree *T){
    if(T==NULL)
        return;
    order(T->l);
    printf("%c",T->d);
    order(T->r);
}
void post(Tree *T){
    if(T==NULL)
        return;
    post(T->l);
    post(T->r);
    printf("%c",T->d);
}
void leave(Tree *T){
    if(T){
        if(!T->l&&!T->r){
            lea++;
        }
        leave(T->l);
        leave(T->r);
    }
}
int deep(Tree *T){
    int ll,rr,m;
    if(T==NULL)
        return 0;
    else{
        ll=deep(T->l);
        rr=deep(T->r);
        m=ll>rr?ll+1:rr+1;
    }
    return m;
}
int main(){
    lea=0,de=0;
    Tree *T;
    Creat(T);
    order(T);
    printf("\n");
    post(T);
    printf("\n");
    leave(T);
    de=deep(T);
    printf("%d\n%d\n",lea,de);
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值