传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1556
Color the ball
Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 23300 Accepted Submission(s): 11320
Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
当N = 0,输入结束。
Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
Sample Input
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
Sample Output
1 1 1 3 2 1
Author
8600
Source
Recommend
LL
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
typedef long long ll;
int c[100005];
int n;
int lowbit(int x){
return x&(-x);
}
void modify(int x,int add){
while(x>0){///更新当前点之前的BIT
c[x]+=add;
x-=lowbit(x);
}
}
int sum(int x){
int ans=0;
while(x<=n){
ans+=c[x];
x+=lowbit(x);
}
return ans;
}
int main(){
int i,j;
int x,y;
while(scanf("%d",&n),n){
memset(c,0,sizeof(c));
for(i=1;i<=n;i++){
scanf("%d %d",&x,&y);
modify(y,1);
modify(x-1,-1);///删掉多加的
}
for(i=1;i<n;i++){
printf("%d ",sum(i));
}
printf("%d\n",sum(n));
}
return 0;
}
区间求和和单点求和的区别,在代码上体现主要是在更新个求和两个函数的一些符号上面