POJ1195——二维BIT基础

一维BIT就有很多应用和变形,二维可以处理很多矩阵类的问题,还有很多BIT套平衡树,扫描线什么的。水平很菜,先从简单题入手吧。。。

首先在网上找到一篇很详细的博文,清楚地解释了树状数组的代码形成,迫不及待的想借鉴一下:http://blog.csdn.net/z309241990/article/details/9615259

传送门http://poj.org/problem?id=1195

Mobile phones
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 20368 Accepted: 9437

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

Source


题意:在一片区域内有一些信号活跃的手机,根据操作会添加手机的位置到原本全为0的区域内,然后统计一些区域内信号活跃的手机的个数

这里有四种操作,这是本体核心

0——一开始初始区域,输入区域面积s*s(只有一次)

1——在指定的位置更新,在指定的位置(x,y)添加v

2——查询区域内的总数,给出横纵坐标的上限和下限(终点就是这里要把加多的减掉)

3——结束,程序结束

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<ctime>
#pragma GCC optimize("03")
#define CL(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long ll;
const ll inf=(ll)1<<60;
const int maxn=1050;
int n,row,col;
ll a[maxn][maxn];
ll c[maxn][maxn];
int lowbit(int x){
    return x&(-x);
}
void modify(int x, int y, int val){
    a[x][y] += val;
    for(int i=x;i<=row;i+=lowbit(i))
        for(int j=y;j<=col;j+=lowbit(j))
            c[i][j] += val;
}
ll sum(int x,int y){
   ll ans=0;
   for(int i=x;i;i-=lowbit(i))
        for(int j=y;j;j-=lowbit(j))
            ans += c[i][j];
   return ans;
}
int main(){
    int i,j;
    int op;
    //freopen("F://2.txt","r",stdin);
    while(~scanf("%d",&op)){
        if(op==0){
            scanf("%d",&n);
            row=col=n;
            CL(c,0);
        }
        if(op==3)
            break;
        if(op==1){
            int x,y,t;
            scanf("%d %d %d",&x,&y,&t);
            modify(x+1,y+1,t);///BIT从1开始
        }
        if(op==2){
            int l,b,r,t;
            scanf("%d%d%d%d",&l,&b,&r,&t);
            printf("%lld\n",sum(r+1,t+1)+sum(l,b)-sum(l,t+1)-sum(r+1,b));///类似容斥
        }
    }
    return 0;
}
/**
0 4
1 1 2 3
2 0 0 2 2
1 1 1 2
1 1 2 -1
2 1 1 2 3
3
**/


这里主要是操作2这里如果不清楚BIT原理可能不太好理解,画了图就很简单了,像代码里说的和容斥一样,后面减多了,后面把多加的补上

一维的sum是只能求1到n的和,扩展到二维就是(1,1)到(n,n)的和

自己还是太菜了




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值