2142 HDU box

 

box

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3730    Accepted Submission(s): 674


Problem Description
One day, winnie received a box and a letter. In the letter, there are three integers and five operations(+,-,*,/,%). If one of the three integers can be calculated by the other two integers using any operations only once.. He can open that mysterious box. Or that box will never be open.
 

Input
The input contains several test cases.Each test case consists of three non-negative integers.
 

Output
If winnie can open that box.print "oh,lucky!".else print "what a pity!"
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
oh,lucky!
 

Author
kiki
 

Source
 

Recommend
威士忌
 
尼期最后一条水题, RE两次, 第一次唔记得判断除数是否为0,第二次加左判断,但系放错地方{=     =}
我见到上面AC率甘底,一开始就用__int64。
 
最后贴贴代码:
 
生气
 
43168552011-08-02 21:18:52Accepted21430MS188K563 BC++10SGetEternal{(。)(。)}!
 
#include <iostream>
using namespace std;

bool jud(__int64 x, __int64 y, __int64 z)
{
    if (
        x + y == z
        || x * y == z
        || x - y == z
        || y - x == z
        || (y != 0 && x % y == z)
        || (x != 0 && y % x == z)
        || (y != 0 && x % y == 0 && x / y == z)
        || (x != 0 && y % x == 0 && y / x == z)
        )
        return 1;
    return 0;
}

int main()
{
    __int64 a, b, c;

    while (scanf("%I64d%I64d%I64d", &a, &b, &c) != EOF)
    {
        if (jud(a, b, c) || jud(a, c, b) || jud(b, c, a))
            puts("oh,lucky!");
        else puts("what a pity!");
    }

    return 0;
}

系时候要搞好多野鸟……………… 奋斗
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值