HDU 2962 Trucking .

27 篇文章 0 订阅
7 篇文章 0 订阅

Trucking

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 796    Accepted Submission(s): 268

Problem Description
A certain local trucking company would like to transport some goods on a cargo truck from one place to another. It is desirable to transport as much goods as possible each trip. Unfortunately, one cannot always use the roads in the shortest route: some roads may have obstacles (e.g. bridge overpass, tunnels) which limit heights of the goods transported. Therefore, the company would like to transport as much as possible each trip, and then choose the shortest route that can be used to transport that amount.

For the given cargo truck, maximizing the height of the goods transported is equivalent to maximizing the amount of goods transported. For safety reasons, there is a certain height limit for the cargo truck which cannot be exceeded.
 

 

Input
The input consists of a number of cases. Each case starts with two integers, separated by a space, on a line. These two integers are the number of cities (C) and the number of roads (R). There are at most 1000 cities, numbered from 1. This is followed by R lines each containing the city numbers of the cities connected by that road, the maximum height allowed on that road, and the length of that road. The maximum height for each road is a positive integer, except that a height of -1 indicates that there is no height limit on that road. The length of each road is a positive integer at most 1000. Every road can be travelled in both directions, and there is at most one road connecting each distinct pair of cities. Finally, the last line of each case consists of the start and end city numbers, as well as the height limit (a positive integer) of the cargo truck. The input terminates when C = R = 0.
 

 

Output
For each case, print the case number followed by the maximum height of the cargo truck allowed and the length of the shortest route. Use the format as shown in the sample output. If it is not possible to reach the end city from the start city, print "cannot reach destination" after the case number. Print a blank line between the output of the cases.
 

 

Sample Input
 
 
5 6 1 2 7 5 1 3 4 2 2 4 -1 10 2 5 2 4 3 4 10 1 4 5 8 5 1 5 10 5 6 1 2 7 5 1 3 4 2 2 4 -1 10 2 5 2 4 3 4 10 1 4 5 8 5 1 5 4 3 1 1 2 -1 100 1 3 10 0 0
 

 

Sample Output
 
 
Case 1: maximum height = 7 length of shortest route = 20 Case 2: maximum height = 4 length of shortest route = 8 Case 3: cannot reach destination
 

 

Source
 

 

Recommend
 
呢个最短路首先要用一次DP求出最高限度,最高限度有D似最大流。
我用左两次最短路,第一次求用Dijkstra最高限度,第二次用SPFA求最短路。
其实求最短路我就系改左Dijkstra内核既松弛技术, 改成求最大流增广路既一种DP。
下面贴代码:
 
42345002011-07-21 10:46:35Accepted2962250MS8092K2613 BC++10SGetEternal{(。)(。)}!
#include<iostream>
#include<queue>
using namespace std;
#define INFI 0x7fffffff
#define MAXI 1001

struct node
{
    int h , w;
} g[MAXI][MAXI];

int v , h , n , dp[MAXI];
bool vis[MAXI];

int Mem_DFS(int s , int minh)
{
    int  i , temph;
    
    if (dp[s] != 0) return dp[s];
    if (s == v) return minh;
    vis[s] = 1;
    
    for (i = 0; i < n; i++)
        if (!vis[i] && !(g[s][i].h == -1 && g[s][i].w == INFI))
        {
            if (g[s][i].h < minh) temph = Mem_DFS(i , g[s][i].h);
            else temph = Mem_DFS(i , minh);
            if (dp[s] < temph) dp[s] = temph;
        }

    vis[s] = 0;

    return dp[s];
}

void Dijkstra(int u , int minh)
{
    int i , j , tmax , temph;

    dp[u] = minh;
    
    for (i = 0; i < n; i++)
    {
        tmax = -11;
        for (j = 0; j < n; j++)
            if (!vis[j] && dp[j] > tmax)
            {
                tmax = dp[j];
                u = j;
            }
        vis[u] = 1;
        for (j = 0; j < n; j++)
            if (!vis[j] && g[u][j].h != -1)
            {
                if (g[u][j].h < dp[u]) temph = g[u][j].h;
                else temph = dp[u];
                if (temph > dp[j]) dp[j] = temph;
            }
    }
}

void SPFA(int u)
{
    int i;

    queue<int> Q;
    Q.push(u);
    vis[u] = 1;
    dp[u] = 0;

    while (!Q.empty())
    {
        u = Q.front();
        Q.pop();
        vis[u] = 0;

        for (i = 0; i < n; i++)
            if (i != u && g[u][i].h >= h && dp[i] - dp[u] > g[u][i].w)
            {
                dp[i] = dp[u] + g[u][i].w;
                if (!vis[i])
                {
                    Q.push(i);
                    vis[i] = 1;
                }
            }
    }

}

int main()
{
    int u , w , m , Case = 0;
    bool ok;
    
    scanf("%d%d" , &n , &m);
    while (n || m)
    {
        ok = 1;
        for (u = 0; u < n; u++)
            for (v = 0; v < n; v++)
            { 
                g[u][v].w = INFI;
                g[u][v].h = -1;
            }
            
        while (m--)
        {
            scanf("%d%d%d%d" , &u , &v , &h , &w);
            u--; v--;
            if (h == -1) h = INFI;
            
            if (g[u][v].h == h)
            {
                if (g[u][v].w > w)
                    g[u][v].w = g[v][u].w = w;
            }
            else if (g[u][v].h < h)
            {
                g[u][v].h = g[v][u].h = h;
                g[u][v].w = g[v][u].w = w;
            }
        }
            
        for (u = 0; u < n; u++) 
        {
            dp[u] = 0;
            vis[u] = 0;
        }
            
        scanf("%d%d%d" , &u , &v , &h);            
        u--; v--;
            
        //dp[v] = Mem_DFS(u , h);

        Dijkstra(u , h);

        if (dp[v] != 0)
        {
            h = dp[v];
            for (w = 0; w < n; w++) 
            {
                dp[w] = INFI;
                vis[w] = 0;
            }

            SPFA(u);

            if (dp[v] != INFI) ok = 1;
        }
        else ok = 0;

        printf("Case %d:\n" , ++Case);

        if (ok)
        {
            printf("maximum height = %d\n" , h);
            printf("length of shortest route = %d\n" , dp[v]);
        }
        else printf("cannot reach destination\n");

        scanf("%d%d" , &n , &m);

        if (n || m) putchar('\n');
    }

    return 0;
}

 其实系水题………………

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值