L2-008 最长对称子串

对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定Is PAT&TAP symmetric?,最长对称子串为s PAT&TAP s,于是你应该输出11。

输入格式:

输入在一行中给出长度不超过1000的非空字符串。

输出格式:

在一行中输出最长对称子串的长度。

输入样例:

Is PAT&TAP symmetric?

输出样例:

11

暴力枚举长度和起点

#include<bits/stdc++.h>
#define INF 0x3f3f3f3f
typedef long long ll;
using namespace std;
const int maxn = 50;
string s;
//stringstream ss;
int main()
{
    getline(cin,s);
    int l = s.size();
//    printf("%d\n",l);
    for(int len = l; len >= 1; len--)
    {
        for(int b = 0;b + len - 1 < l;b++)
        {
            bool sign = true;
            for(int i = b,j = b + len - 1;i <= j; i++,j--)
            {
                if(s[i] != s[j])
                {
                    sign = false;
                    break;
                }
            }
            if(sign)
            {
                printf("%d\n",len);
                return 0;
            }
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值