Prime Path UVA - 12101

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.

— It is a matter of security to change such things every now and then, to keep the enemy in the dark.

— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!

— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.

— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!

— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.

— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.

— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.

— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?

— In fact, I do. You see, there is this programming contest going on. . .

Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.

1033

1733

3733

3739

3779

8779

8179

The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step — a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word ‘Impossible’.

Sample Input

3

1033 8179

1373 8017

1033 1033

Sample Output

6

7

0

一道比赛场下的题目,给出m和n两个四位的素数,每一步只能改变一位数字,且从m到n质检通过变化得到的四位数都必须是素数,问最少需要几步m可以变成n。刚看到这个题没有思路因为这一场是数学专题大概知道和素数有关,看了孙琪学长发的题解,

素筛+BFS 嘻嘻嘻顺带学习了一下BFS,上次看BFS还是寒假刷题的时候那时候看还觉得很难,现在已经可以理解了,学习使我快乐。

对了,我一定要吐槽一下一下VJ,我是在看了题解理解以后自己敲上的,交上以后竟然WA了,QAQ,然后就和题解比对一下也没觉得错,只不过我是用的筛选素数然后打表,就开始怀疑是不是题解错了(哈哈哈,我疯起来我自己都害怕),交上题解AC,然后就改了一下dabiao()这句话的位置,过了一会交上竟然AC了,可是嘤嘤嘤我忘记改了哪里,又试了好几遍才找到。VJ超时竟然不说超时,而是丢给我一个WA......

AC代码

#include <iostream>
#include <algorithm>
#include <queue>
#include <stack>
#include <cstdio>
#include <string>
#include <cstring>
#include <sstream>
#include <cmath>
#include <stack>
#include <map>
#define ll long long
#define INF 0x3f3f3f3f
#define mod 9973
using namespace std;
const int maxn = 100000 + 10;
int m,n;
int vis[maxn],sign[maxn];
void dabiao()
{
    int m = sqrt(maxn + 0.5);
    vis[1] = 1;
    for(int i=2; i<=m; i++)
    {
        if(!vis[i])
        {
            for(int j=i*i; j<=maxn; j+=i)
                vis[j] = 1;
        }
    }
}
struct node
{
    int x,step;
};
queue<node> q;
void bfs()
{
    while(!q.empty())
    {
        node temp = q.front();
        q.pop();
        int ss = temp.step,xx = temp.x;
        if(xx==n)
        {
            printf("%d\n",ss);
            return;
        }
        for(int i=1; i<=9; i+=2)//个位数字
        {
            int s = xx / 10 * 10 + i;
            if(!sign[s]&&!vis[s])
            {
                node nn;
                nn.x = s;
                nn.step = ss + 1;
                sign[s] = 1;
                q.push(nn);
            }
        }
        for(int i=0; i<=9; i++)//十位数字
        {
            int s = xx / 100 * 100 + i * 10 + xx % 10;
            if(!sign[s]&&!vis[s])
            {
                node nn;
                nn.x = s;
                nn.step = ss + 1;
                sign[s] = 1;
                q.push(nn);
            }
        }
        for(int i=0; i<=9; i++)//百位数字
        {
            int s = xx / 1000 * 1000 + i * 100 + xx % 100;
            if(!sign[s]&&!vis[s])
            {
                node nn;
                nn.x = s;
                nn.step = ss + 1;
                sign[s] = 1;
                q.push(nn);
            }
        }
        for(int i=1; i<=9; i++)//千位数字
        {
            int s = i * 1000 + xx % 1000;
            if(!sign[s]&&!vis[s])
            {
                node nn;
                nn.x = s;
                nn.step = ss + 1;
                sign[s] = 1;
                q.push(nn);
            }
        }
    }
    printf("Impossible\n");
}
int main()
{
    int t;
    dabiao();
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&m,&n);
        while(!q.empty()) q.pop();
        memset(sign,0,sizeof(sign));
        node temp;
        temp.x = m;
        temp.step = 0;
        sign[m] = 1;
        q.push(temp);
        bfs();
    }
    return 0;
}

之前WA的代码

#include <iostream>
#include <algorithm>
#include <queue>
#include <stack>
#include <cstdio>
#include <string>
#include <cstring>
#include <sstream>
#include <cmath>
#include <stack>
#include <map>
#define ll long long
#define INF 0x3f3f3f3f
#define mod 9973
using namespace std;
const int maxn = 100000 + 10;
int m,n;
int vis[maxn],sign[maxn];
void dabiao()
{
    int m = sqrt(maxn + 0.5);
    vis[1] = 1;
    for(int i=2; i<=m; i++)
    {
        if(!vis[i])
        {
            for(int j=i*i; j<=maxn; j+=i)
                vis[j] = 1;
        }
    }
}
struct node
{
    int x,step;
};
queue<node> q;
void bfs()
{
    dabiao();
    while(!q.empty())
    {
        node temp = q.front();
        q.pop();
        int ss = temp.step,xx = temp.x;
        if(xx==n)
        {
            printf("%d\n",ss);
            return;
        }
        for(int i=1; i<=9; i+=2)//个位数字
        {
            int s = xx / 10 * 10 + i;
            if(!sign[s]&&!vis[s])
            {
                node nn;
                nn.x = s;
                nn.step = ss + 1;
                sign[s] = 1;
                q.push(nn);
            }
        }
        for(int i=0; i<=9; i++)//十位数字
        {
            int s = xx / 100 * 100 + i * 10 + xx % 10;
            if(!sign[s]&&!vis[s])
            {
                node nn;
                nn.x = s;
                nn.step = ss + 1;
                sign[s] = 1;
                q.push(nn);
            }
        }
        for(int i=0; i<=9; i++)//百位数字
        {
            int s = xx / 1000 * 1000 + i * 100 + xx % 100;
            if(!sign[s]&&!vis[s])
            {
                node nn;
                nn.x = s;
                nn.step = ss + 1;
                sign[s] = 1;
                q.push(nn);
            }
        }
        for(int i=1; i<=9; i++)//千位数字
        {
            int s = i * 1000 + xx % 1000;
            if(!sign[s]&&!vis[s])
            {
                node nn;
                nn.x = s;
                nn.step = ss + 1;
                sign[s] = 1;
                q.push(nn);
            }
        }
    }
    printf("Impossible\n");
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&m,&n);
        while(!q.empty()) q.pop();
        memset(sign,0,sizeof(sign));
        node temp;
        temp.x = m;
        temp.step = 0;
        sign[m] = 1;
        q.push(temp);
        bfs();
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值