题目描述
按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。
输入
第一行输入元素个数n;
第二行输入n个整数。
第二行输入n个整数。
输出
第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。
示例输入
10 21 30 14 55 32 63 11 30 55 30
示例输出
10 30 55 30 11 63 32 55 14 30 21 7 30 55 11 63 32 14 21
提示
来源
不得使用数组!
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define N 1010
struct node
{
int d;
struct node *next;
};
struct node *delet(struct node *head,int n)
{
struct node *p,*q,*tail1,*tail2;
p=head->next;
q=p->next;
while(p->next!=NULL)
{
tail1=p;
while(q!=NULL)
{
if(p->d==q->d)
{
tail2=q;
tail1->next=q->next;
q=q->next;
free(tail2);
n--;
}
else
{
tail1=tail1->next;
q=q->next;
}
}
p=p->next;
q=p->next;
}
printf("%d\n",n);
return(head);
}
int main()
{
struct node *head,*p,*q;
int n,i;
head=new node;
head->next=NULL;
scanf("%d",&n);
for(i=0;i<=n-1;i++)
{
p=new node;
scanf("%d",&p->d);
p->next=NULL;
p->next=head->next;
head->next=p;
}
printf("%d\n",n);
q=head->next;
while(q!=NULL)
{
printf("%d",q->d);
if(q->next!=NULL)
{
printf(" ");
}
q=q->next;
}
printf("\n");
head=delet(head,n);
q=head->next;
while(q!=NULL)
{
printf("%d",q->d);
if(q->next!=NULL)
{
printf(" ");
}
q=q->next;
}
return 0;
}