字典树

题目描述

遇到单词不认识怎么办? 查字典啊,已知字典中有n个单词,假设单词都是由小写字母组成。现有m个不认识的单词,询问这m个单词是否出现在字典中。

输入

含有多组测试用例。
第一行输入n,m (n>=0&&n<=100000&&m>=0&&m<=100000)分别是字典中存在的n个单词和要查询的m个单词.
紧跟着n行,代表字典中存在的单词。
然后m行,要查询的m个单词
n=0&&m=0 程序结束
数据保证所有的单词都是有小写字母组成,并且长度不超过10

输出

若存在则输出Yes,不存在输出No .

示例输入

3 2
aab
aa
ad
ac
ad
0 0

示例输出

No
Yes

///字典树是用来查找单词的,是一种哈兮树的变种

#include<stdio.h>
#include<string.h>
struct node
{
  int next[26];
  int mark;
}st[500000];
int top,n,m;
char a[20],b[20];
int creat()
{
  memset(st[top].next,-1,sizeof(st[top].next));
  st[top].mark=0;
  return top++;
}
int xiab(char c)
{
  return c-'a';
}
void insert(int root,char *s)
{
  int i;
  int len=strlen(s);
  for(i=0;i<=len-1;i++)
  {
    if(st[root].next[xiab(s[i])]==-1)
    st[root].next[xiab(s[i])]=creat();
    root=st[root].next[xiab(s[i])];
  }
  st[root].mark=1;
}
int search(int root,char *s)
{
  int i;
  for(i=0;s[i]!='\0';i++)
  {
    if(st[root].next[xiab(s[i])]==-1)
    return 0;
    root=st[root].next[xiab(s[i])];
  }
  return st[root].mark;
}
int main()
{
  int i,root;
  while(~scanf("%d%d",&n,&m))
  {
    if(n==0 && m==0)
    {
     break;
    }
    else
    {
      top=0;
      root=creat();
      for(i=0;i<=n-1;i++)
      {
        scanf("%s",a);
        insert(root,a);
      }
      for(i=0;i<=m-1;i++)
      {
       scanf("%s",b);
       if(search(root,b))
       printf("Yes\n");
       else
       printf("No\n");
      }
    }
  }

  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值