hdu-1698Just a Hook(线段树 改变部分的值并求和)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 28558    Accepted Submission(s): 14152


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.
 

Source
 

Recommend
wangye   |   We have carefully selected several similar problems for you:   1542  1255  1828  1540  3397 

#include<iostream>
#include<string>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std; 
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define N 111111
int h,w,n;
int col[N<<2];//保存每个的改变形态 
int sum[N<<2];//保存当前所以物品的价值 
void pushup(int rt)
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void pushdown(int rt,int m)//区间更新 
{
	if(col[rt])
	{
		col[rt<<1]=col[rt<<1|1]=col[rt];  //向下标记  直接改变值并非增加某个值 
		sum[rt<<1]=(m-(m>>1))*col[rt];  //m-m>>1 表示左子树的数字数量 
		sum[rt<<1|1]=(m>>1)*col[rt];  //m>>1 表示右子树的数字数量 
		col[rt]=0;
		//清除节点标记
	}
}
void build(int l,int r,int rt)
{
	col[rt]=0;
	sum[rt]=1;
	if(l==r)return;
	int m=(l+r)>>1;
	build(lson);
	build(rson);
	pushup(rt);
}
void update(int L,int R,int c,int l,int r,int rt)
{
	if(L<=l&&R>=r)
	{
		col[rt]=c;
		sum[rt]=c*(r-l+1);//r-l+1表示r到l区间的节点数量 
		return;
	}
	pushdown(rt,r-l+1);//向下标记 
	int m=(l+r)>>1;
	//有交集时递归 
	if(L<=m)
	update(L,R,c,lson);
	if(R>m)
	update(L,R,c,rson);
	pushup(rt);//更新节点数量 
}
int main()
{
	int T,n,m;
	scanf("%d",&T);
	for(int cas=1;cas<=T;cas++)
	{
		scanf("%d%d",&n,&m);
		build(1,n,1);
		while(m--)
		{
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			update(a,b,c,1,n,1);
		}
		printf("Case %d: The total value of the hook is %d.\n",cas,sum[1]);//由于sum[1]是顶点  即 sum[1]的值表示总价值 
	}
	return 0;
}


 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值