HDU CCPC 1005 CaoHaha's staff

Problem Description
"You shall not pass!"
After shouted out that,the Force Staff appered in CaoHaha's hand.
As we all know,the Force Staff is a staff with infinity power.If you can use it skillful,it may help you to do whatever you want.
But now,his new owner,CaoHaha,is a sorcerers apprentice.He can only use that staff to send things to other place.
Today,Dreamwyy come to CaoHaha.Requesting him send a toy to his new girl friend.It was so far that Dreamwyy can only resort to CaoHaha.
The first step to send something is draw a Magic array on a Magic place.The magic place looks like a coordinate system,and each time you can draw a segments either on cell sides or on cell diagonals.In additional,you need 1 minutes to draw a segments.
If you want to send something ,you need to draw a Magic array which is not smaller than the that.You can make it any deformation,so what really matters is the size of the object.
CaoHaha want to help dreamwyy but his time is valuable(to learn to be just like you),so he want to draw least segments.However,because of his bad math,he needs your help.
 

Input
The first line contains one integer T(T<=300).The number of toys.
Then T lines each contains one intetger S.The size of the toy(N<=1e9).
 

Output
Out put T integer in each line ,the least time CaoHaha can send the toy.
 

Sample Input
  
  
5 1 2 3 4 5
 

Sample Output
  
  
4 4 6 6 7

   
   
(大神们不要喷我,我只是一只菜鸟)
题解:题意为N*N 并且单位长度为1的格子,每次可以连接邻边或者对角线,T组测试数据,问围成n面积最少需要多少条边!!	
     纯粹的一道找规律的题,我们每加一条边 都尽可能的将图形拼成正方形(以对角线为边的正方形最大)我们可以很容易
     的求得面积为偶数的最小边数,可以通过减少一条边推出当前的矩形较长边的关系。。。 

   
   
话不多说 直接上代码

#include<iostream>

using namespace std;

int T,n;
unsigned long long ans=0;
int main()
{
    ios::sync_with_stdio(false);
    int a[9]={0,4,4,6,6,7,8,8,8};
    cin>>T;
    while(T--)
    {
        ans=0;
        cin>>n;
        if(n<=4)
            cout<<a[n]<<endl;
        else
        {
            int num=0;
            n-=4;
            int cnt=8;
            while(n>=cnt)
            {
                n-=cnt;
                num+=4;
                cnt+=4;
            }
            int k=1;
            k+=num/4;
            num++;
            if(n>k)
                num++;
            if(n>(2*k+2))
                num++;
            if(n>(3*k+2))
                num++;
            ans=num+a[4];

            cout<<ans<<endl;
        }
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值