POJ to The Max

Time Limit: 1000MS Memory Limit: 10000K
 

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source

题意:
在矩阵array中,搜索一个子矩阵使其各元素之和最大。
我的理解:
假设最优解可以用一个矩形覆盖之,在搜索过程中只需改变其宽,并将宽压缩为一维——将第i列的第s行至k行元素累加。这样就将问题转化成了一维的“求连续元素的最大和问题"。这样一种比较常用的方法就是动态规划法(dp).
一维举例:
数列:3  7  -8 -3 2 -1 10
求解过程:
初始max=0;
step1: dp=3       dp>max  max=dp=3;
step2: dp=3+7=10  dp>max  max=dp=10;
step3: dp=10-8=2    dp<max  max=10;
step4:dp=-1    dp<max  max=10;
step5:dp=0+2 =2  dp<max max=10;
step6:dp=2-1=1   dp<max max=1;
step7:dp=1+10=11 dp>max max=11. 
最终结果为11.
我的代码:

#include<string>
#include<iostream>
#include<fstream>
using namespace std;
int  array[100][100];
int  sumOfRow[100];
int  dp[100];
int main()
{
// ifstream cin("test.txt");
 int n;        // 矩阵的大小
 int i,j,s,t;
 cin>>n;
 while( cin>>n )
 {
  for( i=0; i<n; ++i )
   for( j=0; j<n; ++j )
    cin>>array[i][j];                           // 输入矩阵array
  int max=0;
  // 动态规划求解过程
  for( i=0; i<n; ++i )           
   for( j=0; j<n; ++j )                            // 搜索矩形的起点(左上顶点)
   {
    memset( sumOfRow, 0, sizeof(sumOfRow) );    // 将sumofRow向量值置为0
    for( s=0; s<n; ++s )
     for( t=i; t<=j; ++t )
      sumOfRow[s] += array[t][s];         // 将第s列的第i行至第j行累加,压缩矩形
    memset(dp, 0, sizeof(dp) );                 //
    // 一维求解过程
    for( s=0; s<n; ++s )
    {
     if( s==0 )
      dp[s] = sumOfRow[s];
     else
     {
      dp[s] = ( dp[s-1]>0?dp[s-1]:0 ) + sumOfRow[s] ;
     }
     if( max<dp[s] )
      max = dp[s];
    }
   }
  cout<<max<<endl;
 }
 return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值