usaco2.12Sorting a Three-Valued Sequence

Sorting a Three-Valued Sequence
IOI'96 - Day 2

Sorting is one of the most frequently performed computational tasks. Consider the special sorting problem in which the records to be sorted have at most three different key values. This happens for instance when we sort medalists of a competition according to medal value, that is, gold medalists come first, followed by silver, and bronze medalists come last.

In this task the possible key values are the integers 1, 2 and 3. The required sorting order is non-decreasing. However, sorting has to be accomplished by a sequence of exchange operations. An exchange operation, defined by two position numbers p and q, exchanges the elements in positions p and q.

You are given a sequence of key values. Write a program that computes the minimal number of exchange operations that are necessary to make the sequence sorted.

PROGRAM NAME: sort3

INPUT FORMAT

Line 1:N (1 <= N <= 1000), the number of records to be sorted
Lines 2-N+1:A single integer from the set {1, 2, 3}

SAMPLE INPUT (file sort3.in)

9
2
2
1
3
3
3
2
3
1

OUTPUT FORMAT

A single line containing the number of exchanges required

SAMPLE OUTPUT (file sort3.out)

4

刚开始以为是选择排序 WA了

先把3放在它应该在的位置 并且交换的时候保证1在2的前面 同样再把2换到它该在的位置

/*
    ID: your_id_here
    PROG: sort3
    LANG: C++
*/
#include <iostream>
#include<cstdio>
#include<cstring>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int nu[1010],y[1010];
int main()
{
    freopen("sort3.in","r",stdin);
    freopen("sort3.out","w",stdout);
    int i,j,k,n,s=0,x[5]={0},g=1,t;
    cin>>n;
    for(i = 1; i <= n ; i++)
    {
       cin>>nu[i];
       x[nu[i]]++;
    }
    x[2]+=x[1];
    x[3]+=x[2];
    for(i = 1; i <= x[2] ; i++)
    {
        if(nu[i]==3)
        {
            s++;
            k = i;
            for(j = x[2]+1 ; j <= x[3] ; j++)
                if(nu[j]==1)
                {
                    k = j;
                    break;
                }
            if(k==i)
            {
                for(j = x[2]+1 ; j <= x[3] ; j++)
                    if(nu[j]==2)
                    {
                        k = j;
                        break;
                    }
            }
            t = nu[i];
            nu[i] = nu[k];
            nu[k] = t;
        }
    }
    for(i = 1; i <= x[1] ; i++)
    {
        if(nu[i]==2)
        s++;
    }
    cout<<s<<endl;
    fclose(stdin);
    fclose(stdout);
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值