poj 1700 - Crossing River

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.
Output
For each test case, print a line containing the total number of seconds required for all the N people to cross the river.
Sample Input
1
4
1 2 5 10
Sample Output
17
 
 
题目大意: 第一行输入T代表有T组数据,对于每组数据,然后第二行输入N,表示有N个人,第三行输入这N个人过河的时间,题目规定只有一只船,而且每一次最多只能载两个人,过河时间是两个人中慢的人的时间,求所有人过河的最短时间。
思路:现将时间从小到大排序,然后将N小于等于3的单独分出来,即:
				  if(N == 1) time += a[0];
				  if(N == 2) time += a[1];
				  if(N == 3) time += a[0] + a[1] + a[2];
而后对人数大于4的,将最快的前两个和最慢的两个人分为一组,而这四个人过河有两种方案:
方案一:由第一个带着第二个过河,而后第一个回来,然后倒数第一个和倒数第二个过河,然后让第二个2 划船过来,用时间为time = a[1] + a[0] + a[n - 1] + a[1];
方案二:由第一个人带着第二个,然后第一回来带着倒数第一个,然后回来带着倒数第二个过河,时间为time = a[1] + a[0] +  a[n - 1] + a[0] + a[n - 2];而后比较两次时间花费,采取时间少的累加。
易错点:
一开始只考虑到让时间最少的带着每一个人过河,但其实这并不是最佳方案,应该两种方案合在一起讨论才有最佳方案。
代码如下:
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;


int main()
{
	int T,time;
	int a[1005];
	scanf("%d", &T);
	while(T--){
		int q, n;
		scanf("%d", &n);
		for(int i = 0; i < n; i++){
		scanf("%d", &a[i]);
		}
		sort(a, a + n);
		time = 0;
		int j;
		for( j = n; j > 3; j = j - 2){
			if(2 * a[1] > a[0] + a[j - 2])
			time += 2 * a[0] + a[j - 1] + a[j - 2];
			else 
			time += a[0] + 2 * a[1] + a[j - 1];
		}
		if(j == 1) time += a[0];
		if(j == 2) time += a[1];
		if(j == 3) time += a[0] + a[1] + a[2];
		
		cout << time << endl; 
	}
return  0;
}
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值