并查集

C - A Bug's Life

 

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it. 
InputThe first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.OutputThe output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!


    AC代码:    
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int parent[2005];
int sex[2005];
int fnd(int x)
{
    if(x==parent[x])
        return x;
    int tem = parent[x];
    parent[x] = fnd(parent[x]);
    sex[x] = sex[x]^sex[tem];//sex[x]表示x的自己与父亲节点的关系,sex[tem]表示x的父亲节点与根节点的关系,用于更新x与根节点的关系
    return parent[x];
}
void init(int n)
{
    for(int i=0;i<=n+1;i++)
        {
            parent[i]=i;
            sex[i]=0;
        }
}
int main()
{
    int t,n,m,sb;
    scanf("%d",&t);
    int cas=0;
    while(t--)
    {
        int flag=0;
        cas++;
        int x,y;
        printf("Scenario #%d:\n",cas);
        scanf("%d%d",&sb,&m);
        init(sb);
        for(int j=0;j<m;j++)
        {
            scanf("%d%d",&x,&y);
            if(!flag)
            {
                int xx=fnd(x);
                int yy=fnd(y);
                if(xx==yy&&sex[x]==sex[y])//x,y祖先相同,并且与祖先性别相同,说明为同性,则可确定有同性恋
                    flag=1;
                else
                {
                    parent[xx]=yy;//x,y祖先不同要先合并
                    sex[xx]=!(sex[x]^sex[y]);//xx成为yy的子树后要更新xx与根节点的关系,此时不可确定有无同性恋可认定x,y仍然是异性,则xx与yy的关系为!(sex[x]^sex[y])
                }
            }
        }
        if(flag) printf("Suspicious bugs found!\n\n");
        else printf("No suspicious bugs found!\n\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值