解题报告_sum of consecutive prime numbers

Sum of Consecutive Prime NumbersTime Limit: 1000MS Memory Limit: 65536KTotal Submissions: 26954 Accepted: 14544Description Some positive integers can be represented by a sum of oneor more cons...
摘要由CSDN通过智能技术生成

Sum of Consecutive Prime Numbers 
Time Limit: 1000MS Memory Limit: 65536K 
Total Submissions: 26954 Accepted: 14544

Description Some positive integers can be represented by a sum of one 
or more consecutive prime numbers. How many such representations does 
a given positive integer have? For example, the integer 53 has two 
representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three 
representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has 
only one representation, which is 3. The integer 20 has no such 
representations. Note that summands must be consecutive prime numbers, 
so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the 
integer 20. Your mission is to write a program that reports the number 
of representations for the given positive integer.

Input The input is a sequence of positive integers each in a separate 
line. The integers are between 2 and 10 000, inclusive. The end of the 
input is indicated by a zero.

Output The output should be composed of lines each corresponding to an 
input line except the last zero. An output line includes the number of 
representations for the input integer as the sum of one or more 
consecutive prime numbers. No other characters should be inserted in 
the output.

Sample Input

2 3 17 41 20 666 12 53 0

Sample Output

1 1 2 3 0 0 1 2

Sour

题目大意

给你一个数(1到1w),输出其是否能由连续的素数相加而成,若能输出总共的方案数;否则,输出0

题目思路

先用筛法生成一个素数表,然后对于每个输入的数直接进行枚举

#include<stdio.h>
#include<math.h>
int main()
{
    long long n,a[10000],q,s,p,w,i,k,j,h;
    for(;;)
    {
        w=0;
        q=0;
        s=0;
        scanf("%lld",&n);
        p=n;
        if(n==0)
            break;
        for(i=2; i<=n; i++)
        {
            k=sqrt(i);
            for(j=2; j<=k; j++)
                if(i%j==0)
                    break;
            if(j==k+1)
            {
                a[q++]=i;
                s+=1;
            }
        }
        for(i=s-1; i>=0; i--)
        {
            h=i;
            p=n;
            p=p-a[i];
            for(;;)
            {
                if(p<0)
                    break;
                else if(p!=0)
                {
                    if(h<=0)
                        break;
                    p=p-a[--h];
                }
                else if(p==0)
                {
                    w+=1;
                    break;
                }
            }
        }
        printf("%lld\n",w);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值