Problem A: C++习题 复数类--重载运算符+
Time Limit: 1 Sec Memory Limit: 128 MBSubmit: 438 Solved: 285
[ Submit][ Status][ Web Board]
Description
定义一个复数类Complex,重载运算符“+”,使之能用于复数的加法运算。将运算符函数重载为非成员、非友元的普通函数。编写程序,求两个复数之和。
Input
两个复数
Output
复数之和
Sample Input
3 4 5 -10
Sample Output
(8.00,-6.00i)
HINT
前置代码及类型定义已给定如下,提交时不需要包含,会自动添加到程序前部
/* C++代码 */
#include <iostream>
#include <iomanip>
using namespace std;
class Complex
{
public:
Complex();
Complex(double r,double i);
double get_real();
double get_imag();
void display();
private:
double real;
double imag;
};
主函数已给定如下,提交时不需要包含,会自动添加到程序尾部
/* C++代码 */
int main()
{
double real,imag;
cin>>real>>imag;
Complex c1(real,imag);
cin>>real>>imag;
Complex c2(real,imag);
Complex c3=c1+c2;
cout<<setiosflags(ios::fixed);
cout<<setprecision(2);
c3.display();
return 0;
}
#include <iostream>
#include <iomanip>
using namespace std;
class Complex
{
public:
Complex();
Complex(double r,double i);
double get_real();
double get_imag();
void display();
private:
double real;
double imag;
};
Complex::Complex(double r,double i):real(r),imag(i){}
double Complex::get_real(){return real;}
double Complex::get_imag(){return imag;}
Complex operator + (Complex &a,Complex &b)
{
return Complex(a.get_real() + b.get_real(),a.get_imag()+ b.get_imag());
}
void Complex::display()
{
cout<<'('<<real<<','<<imag<<"i)"<<endl;
}
int main()
{
double real,imag;
cin>>real>>imag;
Complex c1(real,imag);
cin>>real>>imag;
Complex c2(real,imag);
Complex c3=c1+c2;
cout<<setiosflags(ios::fixed);
cout<<setprecision(2);
c3.display();
return 0;
}