Description
A calendar is a system for measuring time, from hours and minutes, to months and days, and finally to years and centuries. The terms of hour, day, month, year and century are all units of time measurements of a calender system.
According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap years, but 1600, 2000, and 2400 are leap years.
Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.
According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap years, but 1600, 2000, and 2400 are leap years.
Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.
Input
The input consists of lines each containing a positive integer, which is the number of days that have elapsed since January 1, 2000 A.D. The last line contains an integer −1, which should not be processed.
You may assume that the resulting date won’t be after the year 9999.
You may assume that the resulting date won’t be after the year 9999.
Output
For each test case, output one line containing the date and the day of the week in the format of "YYYY-MM-DD DayOfWeek", where "DayOfWeek" must be one of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" and "Saturday".
Sample Input
1730 1740 1750 1751 -1
Sample Output
2004-09-26 Sunday 2004-10-06 Wednesday 2004-10-16 Saturday 2004-10-17 Sunday
这道题做了三个多小时,快把我整懵圈了。太郁闷了,一开始错认为2000-1-1日是不算的,第一天就是2000-1-1日,后来才知道不是,我说怎么老是和答案差一天。
好不容易把那一天加上。总算正确了。累啊!!
提示:C++编译器提交提示编译错误(Compile Error)。G++编译器提交OK!
#include <iostream>
#include <iomanip>
using namespace std;
bool isLeapYear(int year)
{
if( ( year % 4 == 0 && year % 100 != 0 ) || ( year % 400 == 0 ) )
return true;
else
return false;
}
int main()
{
int days, year, month, day, pweek, cnt, i;
string weekday;
while( cin >> days && days != -1 )
{
//--------进行日期初始化----------
year = 2000;
month = 1;
day = 1;
weekday = "Saturday\0";
//------------计算哪一年------------
for( i = 366; i < days; ) //从第一天开始算
{
if( isLeapYear( ++year ) )
i += 366;
else
i += 365;
}
if( isLeapYear( year ) ) //计算当年的天数
cnt = days - i + 366;
else
cnt = days - i + 365;
//cout << year << " " << cnt << endl;
//----------计算哪一月份------------
cnt++; //解释这里为什么加1,因为第几天是不算开始时的第一天的,而计算的时候还要把这一天加上
for( i = 31; i < cnt; ) //从第一天开始算
{
month++;
if( month > 12 )
month -= 12, year++;
if( month == 1 || month == 3 || month == 5 || month == 7
|| month == 8 || month == 10 || month == 12 )
i += 31;
else if( month == 2 )
{
if( isLeapYear( year ) )
i += 29;
else
i += 28;
}
else
i += 30;
}
//cout << month << endl;
//----------计算哪一天---------
if( month == 1 || month == 3 || month == 5 || month == 7
|| month == 8 || month == 10 || month == 12 )
day = cnt - i + 31 ;
else if( month == 2 )
{
if( isLeapYear( year ) )
day = cnt - i + 29;
else
day = cnt - i + 28;
}
else
day = cnt - i + 30;
//cout << day << endl;
//------------计算星期几----------------
pweek = ( days + 6 ) % 7;
switch( pweek )
{
case 0 : weekday = "Sunday\0"; break;
case 1 : weekday = "Monday\0"; break;
case 2 : weekday = "Tuesday\0"; break;
case 3 : weekday = "Wednesday\0"; break;
case 4 : weekday = "Thursday\0"; break;
case 5 : weekday = "Friday\0"; break;
case 6 : weekday = "Saturday\0"; break;
}
//cout << weekday << endl;
cout << year << '-' << setfill('0') << setw(2) <<month << '-' << setfill('0') << setw(2) << day << ' '<< weekday << endl;
}
return 0;
}